summaryrefslogtreecommitdiff
path: root/Build/source/texk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/Makefile.am')
-rw-r--r--Build/source/texk/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Build/source/texk/Makefile.am b/Build/source/texk/Makefile.am
new file mode 100644
index 00000000000..62ac31c687f
--- /dev/null
+++ b/Build/source/texk/Makefile.am
@@ -0,0 +1,29 @@
+## Makefile.am for the TeX Live subdirectory texk/
+##
+## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
+## Copyright 2016 Karl Berry <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+## Ensure aclocal.m4 is up to date
+ACLOCAL = @ACLOCAL@ --force
+
+SUBDIRS = . $(MAKE_SUBDIRS)
+DIST_SUBDIRS = $(CONF_SUBDIRS)
+
+# Files not to be distributed
+include $(srcdir)/../am/dist_hook.am
+
+## Configure and build subdirs.
+##
+recurse_this = texk/
+recurse_top = ../
+
+include $(srcdir)/../am/recurse.am
+
+# Common infrastructure for tests
+EXTRA_DIST = tests
+
+# Special target to run TRIP and TRAP tests and create diffs.
+.PHONY: triptrap
+triptrap:
+ cd web2c && $(MAKE) $(AM_MAKEFLAGS) $@