summaryrefslogtreecommitdiff
path: root/Build/source/texk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/Makefile.am')
-rw-r--r--Build/source/texk/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Build/source/texk/Makefile.am b/Build/source/texk/Makefile.am
index f140c5f355f..bdc1e314966 100644
--- a/Build/source/texk/Makefile.am
+++ b/Build/source/texk/Makefile.am
@@ -61,3 +61,9 @@ subtexk: $(CONFIG_AUX)
# Common infrastructure for tests
EXTRA_DIST = tests/common-test.pl
+# Special target to run TRIP and TRAP tests and create diffs.
+.PHONY: triptrap
+triptrap: web2c/Makefile
+ cd web2c && $(MAKE) $(AM_MAKEFLAGS) $@
+web2c/Makefile:
+ $(MAKE) $(AM_MAKEFLAGS) DIST_SUBTEXK=web2c subtexk