summaryrefslogtreecommitdiff
path: root/Build/source/libs/zziplib/zziplib-src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/zziplib/zziplib-src/test/Makefile.am')
-rw-r--r--Build/source/libs/zziplib/zziplib-src/test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/source/libs/zziplib/zziplib-src/test/Makefile.am b/Build/source/libs/zziplib/zziplib-src/test/Makefile.am
index 9b3c08a76bf..f493b07b60f 100644
--- a/Build/source/libs/zziplib/zziplib-src/test/Makefile.am
+++ b/Build/source/libs/zziplib/zziplib-src/test/Makefile.am
@@ -39,7 +39,10 @@ check-local: check-readme $(sfxtests) $(newtests)
check-tests: tests
tests:
@ test -f zziptests.py || cp -s -v $(srcdir)/zziptests.py .
- python zziptests.py -v
+ python zziptests.py --exeext "$(EXEEXT)" --topsrcdir "$(top_srcdir)"
+test_%:
+ @ test -f zziptests.py || cp -s -v $(srcdir)/zziptests.py .
+ python zziptests.py $@ -vvvv --exeext "$(EXEEXT)" --topsrcdir "$(top_srcdir)"
check-readme : $(zzcat) test.zip
@ test -f test.zip || $(MAKE) tmp/../test.zip
@@ -76,3 +79,4 @@ check-sfx : zzshowme$(EXEEXT)
; if test -s readme.out ; then diff readme.out $(README) \
; else grep "libzzip-" readme.err || echo "readme.out is empty!" ; fi
rm readme.out readme.err
+