summaryrefslogtreecommitdiff
path: root/Build/source/libs/zziplib/zziplib-0.13.58/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/zziplib/zziplib-0.13.58/configure.ac')
-rw-r--r--Build/source/libs/zziplib/zziplib-0.13.58/configure.ac54
1 files changed, 34 insertions, 20 deletions
diff --git a/Build/source/libs/zziplib/zziplib-0.13.58/configure.ac b/Build/source/libs/zziplib/zziplib-0.13.58/configure.ac
index fc0c7ff9bbf..61486799e15 100644
--- a/Build/source/libs/zziplib/zziplib-0.13.58/configure.ac
+++ b/Build/source/libs/zziplib/zziplib-0.13.58/configure.ac
@@ -1,16 +1,17 @@
-AC_INIT(zziplib.spec)
+AC_INIT([zziplib.spec])
AC_PREREQ(2.49)
AC_COPYRIGHT([Guido Draheim <guido@gmx.de> for ZZipLib.SF.net])
-AC_REVISION($Revision: 1.6 $)
-AC_CONFIG_AUX_DIR(uses)
+AC_REVISION($Revision: 1.15 $)
+AC_CONFIG_AUX_DIR([uses])
+AC_CONFIG_MACRO_DIR([m4])
# =======================================================================
AC_CANONICAL_SYSTEM
dnl AM_ENABLE_MULTILIB([Makefile],[$host])
AX_ENABLE_BUILDDIR_UNAME
AC_SET_DEFAULT_PATHS_SYSTEM
# -----------------------------------------------------------------------
-AC_ARG_ENABLE(thread-safe,AC_HELP_STRING(
- [--disable-thread-safe],[disable thread-safe libtool option])
+AC_ARG_ENABLE([thread-safe],
+AC_HELP_STRING([--disable-thread-safe],[disable thread-safe libtool option])
,,[ enable_thread_safe="yes"])
THREAD_SAFE=""
test "$enable_thread_safe" = "yes" && THREAD_SAFE="-thread-safe"
@@ -36,7 +37,7 @@ fi
case ".$with_zlib" in
.no|.no,*)
- AC_MSG_RESULT(none)
+ AC_MSG_RESULT(none)
with_zlib="no, not configured" ;;
./usr)
AC_MSG_RESULT([oops, ignored (may try --with-zlib=/usr/.)])
@@ -63,7 +64,7 @@ AC_SUBST(ZLIB_LDIR)
# -----------------------------------------------------------------------
AX_SPEC_DEFAULTS
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
-dnl test ".$CFLAGS" = "." && CFLAGS=""
+dnl test ".$CFLAGS" = "." && CFLAGS=""
AC_PROG_CC
dnl test ".$CFLAGS" = "." && test "$GCC" = "yes" && CFLAGS="-O3"
AC_PROG_INSTALL
@@ -75,16 +76,19 @@ AX_SET_VERSION_INFO
AC_MSG_RESULT([creating zzip/_msvc.in via zzip/_msvc.sed of config.h.in])
test -d zzip || mkdir zzip
sed -f $srcdir/zzip/_msvc.sed $srcdir/config.h.in >zzip/_msvc.in
-AC_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADERS([config.h])
AX_PREFIX_CONFIG_H([zzip/_config.h],[zzip],[config.h])
AX_PREFIX_CONFIG_H([zzip/_msvc.h],[zzip],[zzip/_msvc.in])
AM_MAINTAINER_MODE
AX_CREATE_PKGCONFIG_INFO(dnl
-[zzip/zziplib.pc], [zzip-zlib-config],[-lzzip])
+[zzip/zziplib.pc], [zzip-zlib-config],[-lzzip],,[ ])
# -----------------------------------------------------------------------
+echo extrac.t..
+AX_PAX_TAR_CREATE
+AX_PAX_TAR_EXTRACT
AC_PATH_PROGS(PERL, perl5 perl, echo no perl found for)
-AC_PATH_PROGS(PYTHON, python2.2 python2.3 python, echo no python found for)
+AC_PATH_PROGS(PYTHON, python, echo no python found for)
AC_PATH_PROGS(MKZIP, zip pkzip, :)
AC_PATH_PROGS(XMLTO, xmlto, :)
@@ -109,6 +113,7 @@ AC_COMPILE_CHECK_SIZEOF(short)
AC_COMPILE_CHECK_SIZEOF(int)
AC_COMPILE_CHECK_SIZEOF(long)
AC_C_BIGENDIAN
+AX_CHECK_ALIGNED_ACCESS_REQUIRED
dnl -------------------------------------------------------------
# the default is _disabled_!! anyway, result is prefixed in zzip/_config.h!!
AC_SYS_LARGEFILE_SENSITIVE
@@ -121,7 +126,7 @@ if test ".$ac_cv_sys_largefile_sensitive" = ".no" ; then
elif test ".$with_largefile" != ".no" ; then
AC_MSG_RESULT(compiles library as 64bit off_t variant dnl
- and renaming some function names)
- LARGEFILE_CFLAGS="$LARGEFILE_CFLAGS -D_LARGEFILE_SOURCE"
+ LARGEFILE_CFLAGS="$LARGEFILE_CFLAGS -D_LARGEFILE_SOURCE"
AC_MSG_RESULT(..adding CFLAGS $LARGEFILE_CFLAGS)
CFLAGS="$CFLAGS $LARGEFILE_CFLAGS"
AC_MSG_RESULT(..adding 64 into RELEASE_INFO for the libraries)
@@ -139,7 +144,7 @@ if test "_$ac_cv_header_zlib_h" != "_yes" ; then
AC_MSG_RESULT(dnl
...note: and when linkage fails you might also need to set some LDFLAGS)
case "$prefix" in
- NONE|/usr)
+ NONE|/usr)
AC_MSG_RESULT(dnl
...note: both can be set by specifying the install prefix of the zlib library)
AC_MSG_RESULT(dnl
@@ -179,7 +184,7 @@ case "${with_docdir}" in
no) docdir='${datadir}/doc' ;;
/*|\\*|[a-zA-Z]:*) docdir="$with_docdir" ;;
*) AC_MSG_RESULT(oops)
- AC_MSG_ERROR(bad value ${withval} for --with-docdir)
+ AC_MSG_ERROR(bad value ${withval} for --with-docdir)
;;
esac
AC_SUBST(docdir)
@@ -194,7 +199,7 @@ AC_ARG_WITH(debug, AC_HELP_STRING(
AC_MSG_ERROR(bad value ${withval} for --with-debug) ;;
esac], [with_debug="no"])
test "$with_debug" != "yes" && with_debug="no" # yes or no
-test "$with_debug" = "yes" && export CFLAGS="$CFLAGS -DDEBUG"
+test "$with_debug" = "yes" && export CFLAGS="$CFLAGS -DDEBUG"
result="$with_debug" ; test "$result" = "yes" && result="yes, added -DDEBUG"
AC_MSG_RESULT($result)
if test "$with_debug" = "yes" ; then if test -n "$RELEASE_INFO" ; then
@@ -218,7 +223,7 @@ if test "$with_lowstk" = "auto"; then
esac
fi
test "$with_lowstk" != "yes" && with_lowstk="no" # yes or no
-test "$with_lowstk" = "yes" && CFLAGS="$CFLAGS -D_LOWSTK"
+test "$with_lowstk" = "yes" && CFLAGS="$CFLAGS -D_LOWSTK"
result="$with_lowstk" ; test "$result" = "yes" && result="yes, added -D_LOWSTK"
AC_MSG_RESULT($with_lowstk)
# ---------------------------------------------------------------
@@ -275,12 +280,16 @@ AC_SUBST(ZIPTESTS)
# ---------------------------------------------------------------
AC_MSG_CHECKING(link options)
case "$host_os" in
- mingw*)
+ mingw*)
ZZIPLIB_LDFLAGS="-no-undefined -export-all-symbols -mconsole"
RESOLVES=' '
;;
*)
- ZZIPLIB_LDFLAGS="--export-dynamic"
+
+ if test ".$can_build_shared" = .no
+ then ZZIPLIB_LDFLAGS=""
+ else ZZIPLIB_LDFLAGS="--export-dynamic"
+ fi
RESOLVES=' # '
;;
esac
@@ -291,16 +300,21 @@ AC_SUBST([RESOLVES])
AX_MAINTAINER_MODE_AUTO_SILENT
AX_NOT_ENABLE_FRAME_POINTER
AX_CFLAGS_WARN_ALL
-AX_CFLAGS_NO_WRITABLE_STRINGS
-AX_CFLAGS_STRICT_PROTOTYPES
AX_CFLAGS_GCC_OPTION(-Wpointer-arith)
AX_CFLAGS_GCC_OPTION(-Wsign-compare)
AX_CFLAGS_GCC_OPTION(-Wmissing-declarations)
+AX_CFLAGS_GCC_OPTION(-Wdeclaration-after-statement)
+AX_CFLAGS_GCC_OPTION(-Werror-implicit-function-declaration)
+AX_CFLAGS_GCC_OPTION(-Wstrict-aliasing)
+AX_CFLAGS_GCC_OPTION(-Warray-bounds)
+AX_CFLAGS_NO_WRITABLE_STRINGS
+AX_CFLAGS_STRICT_PROTOTYPES
# ---------------------------------------------------------------
AX_ENABLE_DEFAULT_PKGCONFIGDIR
AX_ENABLE_DEFAULT_ACLOCALDIR
AC_SUBST([CONFIG_FILES])
-AC_OUTPUT([Makefile zzip/Makefile zzipwrap/Makefile SDL/Makefile
+AC_OUTPUT([Makefile
+ zzip/Makefile zzipwrap/Makefile SDL/Makefile
docs/Makefile test/Makefile bins/Makefile])
dnl -------------------------------------------------------------
PATCH_LIBTOOL_ON_DARWIN_ZSH_OVERQUOTING