summaryrefslogtreecommitdiff
path: root/Build/source/libs/zlib/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/zlib/include/Makefile.am')
-rw-r--r--Build/source/libs/zlib/include/Makefile.am18
1 files changed, 3 insertions, 15 deletions
diff --git a/Build/source/libs/zlib/include/Makefile.am b/Build/source/libs/zlib/include/Makefile.am
index b79c908d434..6ee82c6187b 100644
--- a/Build/source/libs/zlib/include/Makefile.am
+++ b/Build/source/libs/zlib/include/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to install zlib headers for TeX Live.
##
-## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -9,21 +9,9 @@
ZLIB_SRC = $(top_srcdir)/$(ZLIB_TREE)
ZLIB_BLD = $(top_builddir)
-ZLIB_HDRS = \
+hdr_links = \
$(ZLIB_SRC)/zlib.h \
$(ZLIB_BLD)/zconf.h
-all-local:
- @for file in $(ZLIB_HDRS); do \
- test -f $$file || continue; \
- inst=`echo $$file | sed -e 's/^.*\///'`; \
- test -f $$inst || { \
- echo "$(LN_S) $$file $$inst"; \
- $(LN_S) $$file $$inst; } || exit 1; \
- done
-
-distclean-local:
- rm -f *.h
-
-
+include $(top_srcdir)/../am/hdr_links.am