summaryrefslogtreecommitdiff
path: root/Build/source/libs/xpdf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/xpdf/Makefile.am')
-rw-r--r--Build/source/libs/xpdf/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Build/source/libs/xpdf/Makefile.am b/Build/source/libs/xpdf/Makefile.am
index 64812782098..998eec25728 100644
--- a/Build/source/libs/xpdf/Makefile.am
+++ b/Build/source/libs/xpdf/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to build xpdf for TeX Live.
##
-## Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -51,6 +51,8 @@ XPDF_SRC = $(top_srcdir)/$(XPDF_TREE)/xpdf
INCLUDES = -Igoo -Ifofi -Ixpdf -I$(GOO_SRC) -I$(FOFI_SRC) -I$(XPDF_SRC)
AM_CPPFLAGS = -DPDF_PARSER_ONLY
+AM_CFLAGS = $(WARNING_CFLAGS)
+AM_CXXFLAGS = $(NO_WARN_CXXFLAGS)
noinst_LIBRARIES = libxpdf.a
@@ -66,8 +68,7 @@ goo_libGoo_a_sources = \
$(GOO_SRC)/GString.cc \
$(GOO_SRC)/gmem.cc \
$(GOO_SRC)/gmempp.cc \
- $(GOO_SRC)/gfile.cc \
- $(GOO_SRC)/parseargs.c
+ $(GOO_SRC)/gfile.cc
fofi_libfofi_a_sources = \
$(FOFI_SRC)/FoFiBase.cc \