summaryrefslogtreecommitdiff
path: root/Build/source/libs/poppler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/poppler/Makefile.am')
-rw-r--r--Build/source/libs/poppler/Makefile.am23
1 files changed, 13 insertions, 10 deletions
diff --git a/Build/source/libs/poppler/Makefile.am b/Build/source/libs/poppler/Makefile.am
index f5aae6c7bcd..e2fb830c3b1 100644
--- a/Build/source/libs/poppler/Makefile.am
+++ b/Build/source/libs/poppler/Makefile.am
@@ -8,10 +8,6 @@
##
ACLOCAL_AMFLAGS = -I ../../m4
-# Rebuild
-.PHONY: rebuild
-rebuild: all
-
## We want to re-distribute the whole original poppler source tree.
##
EXTRA_DIST = $(POPPLER_TREE)
@@ -127,12 +123,19 @@ poppler_libpoppler_a_sources = \
$(libpoppler_a_OBJECTS): config.force
-config.force: $(ZLIB_DEPEND)
- echo timestamp >config.force
- $(SHELL) ./config.status --recheck
-
-DISTCLEANFILES = config.force
-
## Rebuild zlib
@ZLIB_RULE@
+# Reconfig
+reconfig_prereq = $(ZLIB_DEPEND)
+DISTCLEANFILES =
+
+include $(srcdir)/../../am/reconfig.am
+
+# Rebuild
+rebuild_prereq =
+rebuild_target = all
+CLEANFILES =
+
+include $(srcdir)/../../am/rebuild.am
+