summaryrefslogtreecommitdiff
path: root/Build/source/libs/pixman/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/pixman/Makefile.am')
-rw-r--r--Build/source/libs/pixman/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Build/source/libs/pixman/Makefile.am b/Build/source/libs/pixman/Makefile.am
new file mode 100644
index 00000000000..19ab49d3f7d
--- /dev/null
+++ b/Build/source/libs/pixman/Makefile.am
@@ -0,0 +1,49 @@
+## Proxy Makefile.am to build pixman for TeX Live.
+##
+## Copyright (C) 2012 Taco Hoekwater <taco@metatex.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+# Rebuild
+.PHONY: rebuild
+rebuild: all
+
+## We want to re-distribute the whole original pixman source tree.
+##
+EXTRA_DIST = $(PIXMAN_TREE)
+
+## Changes applied to the original source tree
+##
+EXTRA_DIST += $(PIXMAN_TREE)-PATCHES
+
+PIXMAN_SRC = $(PIXMAN_TREE)/pixman
+
+# in case of an SVN repository
+dist-hook:
+ rm -rf `find $(distdir) -name .svn`
+ rm -f $(distdir)/$(PIXMAN_SRC)/pixman-version.h
+
+SUBDIRS = . include
+
+AM_CPPFLAGS = -I$(top_srcdir)/$(PIXMAN_SRC)
+
+noinst_LTLIBRARIES = libpixman.la
+
+include $(srcdir)/sources.am
+
+libpixman_la_SOURCES = $(libpixman_sources) $(libpixman_headers)
+
+if build
+check_PROGRAMS =
+dist_check_SCRIPTS = pixman.test
+TESTS = pixman.test
+endif build
+
+LDADD = libpixman.la
+
+## Files generated by TESTS
+