summaryrefslogtreecommitdiff
path: root/Build/source/libs/mpfr/mpfr-src/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/mpfr/mpfr-src/src/Makefile.am')
-rw-r--r--Build/source/libs/mpfr/mpfr-src/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Build/source/libs/mpfr/mpfr-src/src/Makefile.am b/Build/source/libs/mpfr/mpfr-src/src/Makefile.am
index d9e89108ddb..74e1473cfd5 100644
--- a/Build/source/libs/mpfr/mpfr-src/src/Makefile.am
+++ b/Build/source/libs/mpfr/mpfr-src/src/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright 2000-2018 Free Software Foundation, Inc.
+# Copyright 2000-2019 Free Software Foundation, Inc.
# This Makefile.am is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -81,7 +81,7 @@ libmpfr_la_LIBADD = @LIBOBJS@
# 3.0.x 4:x:0
# 3.1.x 5:x:1
# 4.0.x 6:x:0
-libmpfr_la_LDFLAGS = $(MPFR_LDFLAGS) $(LIBMPFR_LDFLAGS) -version-info 6:1:0
+libmpfr_la_LDFLAGS = $(MPFR_LDFLAGS) $(LIBMPFR_LDFLAGS) -version-info 6:2:0
# Important note: If for some reason, srcdir is read-only at build time
# (and you use objdir != srcdir), then you need to rebuild get_patches.c
@@ -134,12 +134,12 @@ check-gmp-symbols: $(LTLIBRARIES)
# For instance, with r11968, and
# ./configure --with-gmp-build=... CC=tcc
# the symbol __gmpn_clz_tab is defined, which is wrong.
-# Note: the "grep -v '@plt$$'" below is for tcc.
+# Note: the "$(GREP) -v '@plt$$'" below is for tcc.
check-exported-symbols: $(LTLIBRARIES)
if [ -f "$(LIBMPFRSO)" ]; then \
gsymbols=`$(NM) -gP "$(LIBMPFRSO)" | perl -ne \
'/^(__gmp[a-z]?_[_0-9A-Za-z]*) +[A-TV-Z]/ and print " $$1"' | \
- grep -v '@plt$$'`; \
+ { $(GREP) -v '@plt$$' || true ; }`; \
if [ -n "$$gsymbols" ]; then \
echo "MPFR defines symbols with a GMP reserved prefix:$$gsymbols"; \
exit 1; \