summaryrefslogtreecommitdiff
path: root/Build/source/libs/luajit/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/luajit/include/Makefile.am')
-rw-r--r--Build/source/libs/luajit/include/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Build/source/libs/luajit/include/Makefile.am b/Build/source/libs/luajit/include/Makefile.am
new file mode 100644
index 00000000000..6634fd88b19
--- /dev/null
+++ b/Build/source/libs/luajit/include/Makefile.am
@@ -0,0 +1,23 @@
+## Proxy Makefile.am to install luajit headers for TeX Live.
+##
+## Copyright (C) 2014 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+LUAJIT_SRC = $(top_srcdir)/$(LUAJIT_TREE)/src
+
+hdr_links = \
+ $(LUAJIT_SRC)/lauxlib.h \
+ $(LUAJIT_SRC)/lj_arch.h \
+ $(LUAJIT_SRC)/lj_def.h \
+ $(LUAJIT_SRC)/lj_obj.h \
+ $(LUAJIT_SRC)/lj_state.h \
+ $(LUAJIT_SRC)/lua.h \
+ $(LUAJIT_SRC)/luaconf.h \
+ $(LUAJIT_SRC)/luajit.h \
+ $(LUAJIT_SRC)/lualib.h
+
+include $(top_srcdir)/../../am/hdr_links.am
+