summaryrefslogtreecommitdiff
path: root/Build/source/libs/lua52/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/lua52/Makefile.am')
-rw-r--r--Build/source/libs/lua52/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/Build/source/libs/lua52/Makefile.am b/Build/source/libs/lua52/Makefile.am
index 3eb696515d6..220fdb6f482 100644
--- a/Build/source/libs/lua52/Makefile.am
+++ b/Build/source/libs/lua52/Makefile.am
@@ -16,16 +16,18 @@ EXTRA_DIST += $(LUA52_TREE)-PATCHES
# in case of an SVN repository
dist-hook:
- rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name '*.$(OBJEXT)'`
+ rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name .libs -o -name '*.o' -o -name '*.lo'`
SUBDIRS = . include
AM_CPPFLAGS = -I$(top_srcdir)/$(LUA52_TREE)/src $(LUA52_DEFINES)
AM_CFLAGS = $(WARNING_CFLAGS)
-noinst_LIBRARIES = liblua52.a
+lib_LTLIBRARIES = libtexlua52.la
-nodist_liblua52_a_SOURCES = \
+libtexlua52_la_LDFLAGS = -bindir @bindir@ -no-undefined -version-info $(LUA52_LT_VERSINFO)
+
+nodist_libtexlua52_la_SOURCES = \
@LUA52_TREE@/src/lapi.c \
@LUA52_TREE@/src/lauxlib.c \
@LUA52_TREE@/src/lbaselib.c \
@@ -60,6 +62,20 @@ nodist_liblua52_a_SOURCES = \
@LUA52_TREE@/src/lvm.c \
@LUA52_TREE@/src/lzio.c
+
+lua52includedir = ${includedir}/texlua52
+
+lua52include_HEADERS = \
+ $(LUA52_TREE)/src/lauxlib.h \
+ $(LUA52_TREE)/src/luaconf.h \
+ $(LUA52_TREE)/src/lua.h \
+ $(LUA52_TREE)/src/lua.hpp \
+ $(LUA52_TREE)/src/lualib.h
+
+pkgconfigdir = ${libdir}/pkgconfig
+
+pkgconfig_DATA = texlua52.pc
+
if build
check_PROGRAMS = luatest luatry
dist_check_SCRIPTS = lua52.test luaerror.test
@@ -74,10 +90,10 @@ nodist_luatry_SOURCES = @LUA52_TREE@/src/lua.c
luatry_CPPFLAGS = -Iinclude
-LDADD = liblua52.a
+LDADD = libtexlua52.la
EXTRA_DIST += error.exp
-CLEANFILES = error.out
+CLEANFILES = error.out error.tmp
# Rebuild
rebuild_prereq =