summaryrefslogtreecommitdiff
path: root/Build/source/libs/libpng/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/libpng/include/Makefile.am')
-rw-r--r--Build/source/libs/libpng/include/Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/Build/source/libs/libpng/include/Makefile.am b/Build/source/libs/libpng/include/Makefile.am
index 0c361096ecc..7d799db771c 100644
--- a/Build/source/libs/libpng/include/Makefile.am
+++ b/Build/source/libs/libpng/include/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to install libpng headers for TeX Live.
##
-## Copyright (C) 2009, 2011 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -8,20 +8,10 @@
##
LIBPNG_SRC = $(top_srcdir)/$(LIBPNG_TREE)
-LIBPNG_HDRS = \
+hdr_links = \
$(LIBPNG_SRC)/png.h \
$(LIBPNG_SRC)/pngconf.h \
$(LIBPNG_SRC)/pnglibconf.h
-all-local:
- @for file in $(LIBPNG_HDRS); do \
- test -f $$file || continue; \
- inst=`echo $$file | sed -e 's/^.*\///'`; \
- test -f $$inst || { \
- echo "$(LN_S) $$file $$inst"; \
- $(LN_S) $$file $$inst; } || exit 1; \
- done
-
-distclean-local:
- rm -f *.h
+include $(top_srcdir)/../am/hdr_links.am