summaryrefslogtreecommitdiff
path: root/Build/source/libs/icu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/icu/Makefile.am')
-rw-r--r--Build/source/libs/icu/Makefile.am23
1 files changed, 15 insertions, 8 deletions
diff --git a/Build/source/libs/icu/Makefile.am b/Build/source/libs/icu/Makefile.am
index c01e7235331..2dc2aef28bb 100644
--- a/Build/source/libs/icu/Makefile.am
+++ b/Build/source/libs/icu/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to build ICU for TeX Live.
##
-## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -16,18 +16,12 @@ rebuild: icubuild
SUBDIRS = .
## We want to re-distribute the whole ICU source tree.
-EXTRA_DIST = $(ICU_TREE)
-
-EXTRA_DIST += license.html
+EXTRA_DIST = $(ICU_TREE) license.html
## Patches applied to the original source tree
##
EXTRA_DIST += $(ICU_TREE)-PATCHES
-## Prepare for icu-4.4
-##
-EXTRA_DIST += icu-4.4 icu-4.4-PATCHES
-
# in case of an SVN repository
dist-hook:
rm -rf `find $(distdir) -name .svn`
@@ -69,6 +63,19 @@ if cross
cd icu-native && $(MAKE) $(AM_MAKEFLAGS) all
endif cross
cd icu-build && $(MAKE) $(AM_MAKEFLAGS) all
+## For ICU versions <= 4.2.1, the static libraries were called
+## libsicuxxx.a, but this is not longer generally true for ICU 4.4.
+## In order to have uniform LDFLAGS, we therefore create symlinks
+## libsicuxxx.a -> libicuxxx.a as required.
+## Can't do this the other way around, because for AIX shared and
+## and static libraries both have the extension '.a'.
+ @cd icu-build/lib && for lib in libicu*.a; do \
+ test -f "$$lib" || continue; \
+ libs=`echo "$$lib" | sed 's/libicu/libsicu/'`; \
+ test -f "$$libs" && continue; \
+ echo "creating link '$$libs' -> '$$lib'"; \
+ $(LN_S) "$$lib" "$$libs" || exit 1; \
+ done
check-makeflags:
@for f in x $$MAKEFLAGS; do \