summaryrefslogtreecommitdiff
path: root/Build/source/libs/graphite/test/RegressionTest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/graphite/test/RegressionTest/Makefile.am')
-rw-r--r--Build/source/libs/graphite/test/RegressionTest/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Build/source/libs/graphite/test/RegressionTest/Makefile.am b/Build/source/libs/graphite/test/RegressionTest/Makefile.am
new file mode 100644
index 00000000000..fe59b65fbaa
--- /dev/null
+++ b/Build/source/libs/graphite/test/RegressionTest/Makefile.am
@@ -0,0 +1,38 @@
+AUTOMAKE_OPTIONS = 1.6
+
+EXTRA_DIST = \
+ burmeseText.wpx \
+ romanText.wpx \
+ xlineText.wpx \
+ grtest_arabic.ttf \
+ grtest_badVersion.ttf \
+ grtest_badCmap.ttf \
+ grtest_burmese.ttf \
+ grtest_roman.ttf \
+ grtest_taiviet.ttf \
+ grtest_xline.ttf \
+ xline.gdl \
+ Makefile.vc \
+ makedebug.bat \
+ readme.txt
+
+noinst_PROGRAMS = regression-test
+
+AM_CPPFLAGS = -I$(top_srcdir)/include/graphite
+
+regression_test_LDFLAGS = -L$(top_builddir)/src -lgraphite
+
+regression_test_SOURCES = \
+ main.h \
+ stdafx.cpp stdafx.h \
+ RegressionTest.cpp \
+ TestCase.cpp TestCase.h \
+ RtTextSrc.h \
+ SimpleTextSrc.cpp SimpleTextSrc.h \
+ GrJustifier.cpp GrJustifier.h
+
+check-local: regression-test
+ $(top_builddir)/test/RegressionTest/regression-test -p $(srcdir)
+
+dist-hook:
+ rm -f grregtest.log tracelog.txt