summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/libgd-src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/libgd-src/configure.ac')
-rw-r--r--Build/source/libs/gd/libgd-src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/Build/source/libs/gd/libgd-src/configure.ac b/Build/source/libs/gd/libgd-src/configure.ac
index 9d3d1fe5b59..7663cccf06e 100644
--- a/Build/source/libs/gd/libgd-src/configure.ac
+++ b/Build/source/libs/gd/libgd-src/configure.ac
@@ -300,7 +300,8 @@ AX_CFLAGS_WARN_ALL
dnl Enable -Werror if possible. Do it after all other tests.
AC_ARG_ENABLE([werror], [AS_HELP_STRING([--enable-werror], [treat compile warnings as errors])])
-if test "$enable_werror" = "yes" || test "$GCC" = "yes" -a "$enable_werror" != "no"; then
+if test "$enable_werror" = "yes" || \
+ test "$GCC" = "yes" -a "$enable_werror" != "no" -a -d "$srcdir/.git"; then
CFLAGS="-Werror $CFLAGS"
CXXFLAGS="-Werror $CXXFLAGS"
fi
@@ -324,7 +325,6 @@ AC_MSG_RESULT([
AC_CONFIG_FILES([Makefile
src/Makefile
tests/Makefile
- tests/test_config.h
config/Makefile
config/gdlib-config
config/gdlib.pc])