summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/libgd-2.1.0-rc1/tests/gdimagefilledrectangle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/libgd-2.1.0-rc1/tests/gdimagefilledrectangle/CMakeLists.txt')
-rw-r--r--Build/source/libs/gd/libgd-2.1.0-rc1/tests/gdimagefilledrectangle/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Build/source/libs/gd/libgd-2.1.0-rc1/tests/gdimagefilledrectangle/CMakeLists.txt b/Build/source/libs/gd/libgd-2.1.0-rc1/tests/gdimagefilledrectangle/CMakeLists.txt
new file mode 100644
index 00000000000..9a82b99ea01
--- /dev/null
+++ b/Build/source/libs/gd/libgd-2.1.0-rc1/tests/gdimagefilledrectangle/CMakeLists.txt
@@ -0,0 +1,12 @@
+SET(TESTS_FILES
+ bug00004
+ bug00078
+ bug00106_gdimagefilledrectangle
+)
+
+FOREACH(test_name ${TESTS_FILES})
+ add_executable(${test_name} "${test_name}.c")
+ target_link_libraries (${test_name} gdTest)
+ get_target_property(test_path ${test_name} LOCATION)
+ ADD_TEST(${test_name} ${test_path})
+ENDFOREACH(test_name)