summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/include/Makefile.am')
-rw-r--r--Build/source/libs/gd/include/Makefile.am18
1 files changed, 3 insertions, 15 deletions
diff --git a/Build/source/libs/gd/include/Makefile.am b/Build/source/libs/gd/include/Makefile.am
index 3662692f58d..96940a3bd16 100644
--- a/Build/source/libs/gd/include/Makefile.am
+++ b/Build/source/libs/gd/include/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to install headers headers for TeX Live.
##
-## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -8,7 +8,7 @@
##
GD_SRC = $(top_srcdir)/$(GD_TREE)
-GD_HDRS = \
+hdr_links = \
$(GD_SRC)/entities.h \
$(GD_SRC)/gd.h \
$(GD_SRC)/gd_io.h \
@@ -23,17 +23,5 @@ GD_HDRS = \
$(GD_SRC)/jisx0208.h \
$(GD_SRC)/wbmp.h
-all-local:
- @for file in $(GD_HDRS); do \
- test -f $$file || continue; \
- inst=`echo $$file | sed -e 's/^.*\///'`; \
- test -f $$inst || { \
- echo "$(LN_S) $$file $$inst"; \
- $(LN_S) $$file $$inst; } || exit 1; \
- done
-
-distclean-local:
- rm -f *.h
-
-
+include $(top_srcdir)/../am/hdr_links.am