summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/Makefile.am')
-rw-r--r--Build/source/libs/gd/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/Build/source/libs/gd/Makefile.am b/Build/source/libs/gd/Makefile.am
index c972c77881e..5b043bd13a4 100644
--- a/Build/source/libs/gd/Makefile.am
+++ b/Build/source/libs/gd/Makefile.am
@@ -22,10 +22,9 @@ dist-hook:
INCLUDES = -I$(top_srcdir)/$(GD_TREE) $(ZLIB_INCLUDES) $(LIBPNG_INCLUDES)
if build
-
noinst_LIBRARIES=libgd.a
-
endif build
+EXTRA_LIBRARIES=libgd.a
nodist_libgd_a_SOURCES = \
$(GD_TREE)/gd.c \
@@ -72,15 +71,15 @@ BUILT_SOURCES = \
jisx0208.h \
wbmp.h
-$(BUILT_SOURCES): stamp-gd
-
-libgd_a_DEPENDENCIES = $(ZLIB_DEPEND) $(LIBPNG_DEPEND)
+$(libgd_a_OBJECTS): $(BUILT_SOURCES) $(ZLIB_DEPEND) $(LIBPNG_DEPEND)
## Rebuild zlib
@ZLIB_RULE@
## Rebuild libpng
@LIBPNG_RULE@
+$(BUILT_SOURCES): stamp-gd
+
stamp-gd:
@for file in $(BUILT_SOURCES); do \
test -f $$file || { \
@@ -92,7 +91,3 @@ stamp-gd:
distclean-local:
rm -f stamp-gd $(BUILT_SOURCES)
-## Eventually delete these files
-##
-EXTRA_DIST += Makefile.in.orig configure.in.orig
-