summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/Makefile.am')
-rw-r--r--Build/source/libs/gd/Makefile.am60
1 files changed, 30 insertions, 30 deletions
diff --git a/Build/source/libs/gd/Makefile.am b/Build/source/libs/gd/Makefile.am
index 7467539c065..0fb85f3088e 100644
--- a/Build/source/libs/gd/Makefile.am
+++ b/Build/source/libs/gd/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to build libpng for TeX Live.
##
-## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -22,7 +22,7 @@ EXTRA_DIST += $(GD_TREE)-PATCHES
# in case of an SVN repository
dist-hook:
- rm -rf `find $(distdir) -name .svn`
+ rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name '*.$(OBJEXT)'`
rm -f $(distdir)/$(GD_TREE)/config/config.guess \
$(distdir)/$(GD_TREE)/config/config.rpath \
$(distdir)/$(GD_TREE)/config/config.sub \
@@ -44,34 +44,34 @@ AM_CPPFLAGS += -DNONDLL
noinst_LIBRARIES=libgd.a
libgd_a_SOURCES = \
- $(GD_TREE)/gd.c \
- $(GD_TREE)/gd_gd.c \
- $(GD_TREE)/gd_gd2.c \
- $(GD_TREE)/gd_gif_in.c \
- $(GD_TREE)/gd_gif_out.c \
- $(GD_TREE)/gd_io.c \
- $(GD_TREE)/gd_io_dp.c \
- $(GD_TREE)/gd_io_file.c \
- $(GD_TREE)/gd_io_ss.c \
- $(GD_TREE)/gd_jpeg.c \
- $(GD_TREE)/gd_png.c \
- $(GD_TREE)/gd_security.c \
- $(GD_TREE)/gd_ss.c \
- $(GD_TREE)/gd_topal.c \
- $(GD_TREE)/gd_wbmp.c \
- $(GD_TREE)/gdcache.c \
- $(GD_TREE)/gdfontg.c \
- $(GD_TREE)/gdfontl.c \
- $(GD_TREE)/gdfontmb.c \
- $(GD_TREE)/gdfonts.c \
- $(GD_TREE)/gdfontt.c \
- $(GD_TREE)/gdft.c \
- $(GD_TREE)/gdfx.c \
- $(GD_TREE)/gdhelpers.c \
- $(GD_TREE)/gdkanji.c \
- $(GD_TREE)/gdtables.c \
- $(GD_TREE)/gdxpm.c \
- $(GD_TREE)/wbmp.c
+ @GD_TREE@/gd.c \
+ @GD_TREE@/gd_gd.c \
+ @GD_TREE@/gd_gd2.c \
+ @GD_TREE@/gd_gif_in.c \
+ @GD_TREE@/gd_gif_out.c \
+ @GD_TREE@/gd_io.c \
+ @GD_TREE@/gd_io_dp.c \
+ @GD_TREE@/gd_io_file.c \
+ @GD_TREE@/gd_io_ss.c \
+ @GD_TREE@/gd_jpeg.c \
+ @GD_TREE@/gd_png.c \
+ @GD_TREE@/gd_security.c \
+ @GD_TREE@/gd_ss.c \
+ @GD_TREE@/gd_topal.c \
+ @GD_TREE@/gd_wbmp.c \
+ @GD_TREE@/gdcache.c \
+ @GD_TREE@/gdfontg.c \
+ @GD_TREE@/gdfontl.c \
+ @GD_TREE@/gdfontmb.c \
+ @GD_TREE@/gdfonts.c \
+ @GD_TREE@/gdfontt.c \
+ @GD_TREE@/gdft.c \
+ @GD_TREE@/gdfx.c \
+ @GD_TREE@/gdhelpers.c \
+ @GD_TREE@/gdkanji.c \
+ @GD_TREE@/gdtables.c \
+ @GD_TREE@/gdxpm.c \
+ @GD_TREE@/wbmp.c
$(libgd_a_OBJECTS): config.force