summaryrefslogtreecommitdiff
path: root/Build/source/extra/xz/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/extra/xz/tests/Makefile.am')
-rw-r--r--Build/source/extra/xz/tests/Makefile.am55
1 files changed, 0 insertions, 55 deletions
diff --git a/Build/source/extra/xz/tests/Makefile.am b/Build/source/extra/xz/tests/Makefile.am
deleted file mode 100644
index c4e17ed1dd7..00000000000
--- a/Build/source/extra/xz/tests/Makefile.am
+++ /dev/null
@@ -1,55 +0,0 @@
-##
-## Author: Lasse Collin
-##
-## This file has been put into the public domain.
-## You can do whatever you want with this file.
-##
-
-EXTRA_DIST = \
- files \
- tests.h \
- test_files.sh \
- test_compress.sh \
- test_scripts.sh \
- bcj_test.c \
- compress_prepared_bcj_sparc \
- compress_prepared_bcj_x86
-
-AM_CPPFLAGS = \
- -I$(top_srcdir)/src/common \
- -I$(top_srcdir)/src/liblzma/api \
- -I$(top_builddir)/lib
-
-LDADD = $(top_builddir)/src/liblzma/liblzma.la
-
-if COND_GNULIB
-LDADD += $(top_builddir)/lib/libgnu.a
-endif
-
-LDADD += $(LTLIBINTL)
-
-check_PROGRAMS = \
- create_compress_files \
- test_check \
- test_stream_flags \
- test_filter_flags \
- test_block_header \
- test_index \
- test_bcj_exact_size
-
-TESTS = \
- test_check \
- test_stream_flags \
- test_filter_flags \
- test_block_header \
- test_index \
- test_bcj_exact_size \
- test_files.sh \
- test_compress.sh
-
-if COND_SCRIPTS
-TESTS += test_scripts.sh
-endif
-
-clean-local:
- -rm -f compress_generated_*