summaryrefslogtreecommitdiff
path: root/Build/source/extra/xz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/extra/xz/Makefile.am')
-rw-r--r--Build/source/extra/xz/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/source/extra/xz/Makefile.am b/Build/source/extra/xz/Makefile.am
index 749494c4f6d..9d6cf1ec62a 100644
--- a/Build/source/extra/xz/Makefile.am
+++ b/Build/source/extra/xz/Makefile.am
@@ -77,5 +77,9 @@ dist-hook:
# This works with GNU tar and gives cleaner package than normal 'make dist'.
mydist:
+ if test -d "$(srcdir)/.git" && type git > /dev/null 2>&1; then \
+ SNAPSHOT=`cd "$(srcdir)" && git describe --abbrev=4 | cut -b2-`; \
+ test -n "$$SNAPSHOT" && VERSION=$$SNAPSHOT; \
+ fi; \
TAR_OPTIONS='--owner=0 --group=0 --numeric-owner --mode=u+rw,go+r-w' \
- $(MAKE) dist-gzip
+ $(MAKE) VERSION="$$VERSION" dist-gzip