summaryrefslogtreecommitdiff
path: root/Build/source/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/doc/Makefile.am')
-rw-r--r--Build/source/doc/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/Build/source/doc/Makefile.am b/Build/source/doc/Makefile.am
index d968fb66dcf..d254f6fa0ea 100644
--- a/Build/source/doc/Makefile.am
+++ b/Build/source/doc/Makefile.am
@@ -1,6 +1,7 @@
+## $Id$
## Makefile.am for the TeX Live subdirectory ./doc/
##
-## Copyright 2015-2018 Karl Berry <tex-live@tug.org>
+## Copyright 2015-2020 Karl Berry <tex-live@tug.org>
## Copyright 2013-2015 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
@@ -29,7 +30,7 @@ readme-install: readme-files
svn diff $(top_srcdir)/README.* >/tmp/sd
svn status $(top_srcdir)/README.*
#
-.PHONY: readme-files readme-install
+.PHONY: readme-files readme-install script-links
# autogenerate texinfo from install-tl and tlmgr pod.
# none of this is intended to be executed except manually.
@@ -68,10 +69,14 @@ install_node_good = ref{tlmgr install [\@emph{option}...] \@emph{pkg}...,
# we don't actually use the (autogenerated) -incl.texi file,
# but it makes for a convenient target.
-#
+
# First make symlinks in build dir:
-# ln -s .../tlmgr.pl .../Build/source/Work/doc
-# ln -s .../install-tl .../Build/source/Work/doc
+Master = $(top_srcdir)/../../Master
+script-links:
+ rm -f tlmgr.pl install-tl
+ ln -s $(Master)/install-tl .
+ ln -s $(Master)/texmf-dist/scripts/texlive/tlmgr.pl .
+
$(mydoc)-incl.texi: install-tl tlmgr.pl
$(pod2texi) -o $@ --subdir=$(mydoc)-incl $(pod2texi_args) $^
cp $(mydoc)-incl/tlmgr.texi $(mydoc)-incl/tlmgr.texi.orig