summaryrefslogtreecommitdiff
path: root/Build/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/configure.in')
-rw-r--r--Build/source/configure.in28
1 files changed, 15 insertions, 13 deletions
diff --git a/Build/source/configure.in b/Build/source/configure.in
index 97389304a77..0af317d2036 100644
--- a/Build/source/configure.in
+++ b/Build/source/configure.in
@@ -259,19 +259,21 @@ test "$needs_obsdcompat" = yes \
AC_CONFIG_SUBDIRS([libs])
-PKGS='dialog lcdf-typetools lzma-utils mkjobtexmf pdfopen ps2eps psutils t1utils texcount texi2html texinfo tpic2pdftex'
-ESUBDIRS=
-test -d utils || mkdir utils
-for pkg in $PKGS; do
- if test -d $srcdir/utils/$pkg; then
- if eval "test \"`echo '$with_'${pkg}|sed 's/-/_/g'`\" != no"; then
- ESUBDIRS="$ESUBDIRS utils/$pkg"
- AC_CONFIG_SUBDIRS([utils/$pkg])
- fi
- fi
-done
-
-AC_SUBST(ESUBDIRS)
+KPSE_CONFIG_SUBDIRS([
+ dialog
+ lcdf-typetools
+ lzma-utils
+ mkjobtexmf
+ pdfopen
+ ps2eps
+ psutils
+ t1utils
+ texcount
+ texi2html
+ texinfo
+ tpic2pdftex
+], [utils])
+
AC_SUBST(LIBSDEP)
AC_SUBST(LIBSDIRS)