summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index 5c4c6b07b8f..d0071c906a5 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -94,7 +94,9 @@ AC_CONFIG_FILES([Makefile])
AC_OUTPUT
AS_IF([test "x$cross_compiling" = xyes],
- [msg_compiling="cross-compiling on $build"],
+ [AS_IF([test "x$build" = x],
+ [AC_MSG_ERROR([when cross-compiling you must specify both --host and --build.])])
+ msg_compiling="cross-compiling on $build"],
[msg_compiling="compiling"])
AC_MSG_RESULT([
** Configuration summary for $PACKAGE_STRING: