summaryrefslogtreecommitdiff
path: root/Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2016-06-11 23:04:41 +0000
committerKarl Berry <karl@freefriends.org>2016-06-11 23:04:41 +0000
commitc44a21c04063b38b9c04a092c51a2e7d39b94ecf (patch)
treea8835454f9eb5fba9f2a7f0f02d33d99c89cf331 /Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac
parent9206954046a4680fba774804c1667732923bfc56 (diff)
fonts-tlwg (11jun16)
git-svn-id: svn://tug.org/texlive/trunk@41366 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac')
-rw-r--r--Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac b/Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac
index 4c3a8f73dbd..f2e48eeded1 100644
--- a/Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac
+++ b/Master/texmf-dist/source/fonts/fonts-tlwg/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.59)
-AC_INIT(fonts-tlwg, 0.6.1, thai-linux-foss-devel@googlegroups.com)
+AC_INIT(fonts-tlwg, 0.6.3, thai-linux-foss-devel@googlegroups.com)
AC_CONFIG_SRCDIR([nf/Garuda.sfd])
AM_INIT_AUTOMAKE(dist-xz no-dist-gzip -Wno-portability)
@@ -57,6 +57,21 @@ if test "x$enable_otf" = "xyes"; then
AC_SUBST(otfdir)
fi
+AC_ARG_ENABLE(woff,
+ [AC_HELP_STRING([--enable-woff],
+ [enable Web Open Font Format generation])],
+ , enable_woff="no")
+if test "x$enable_woff" = "xyes"; then
+ AC_ARG_WITH(woffdir,
+ [AC_HELP_STRING([--with-woffdir=DIR],
+ [font directory in DIR [PREFIX/share/fonts/woff/thai]])],
+ [woffdir="$withval"], [woffdir=\$\{prefix\}/share/fonts/woff/thai])
+ AC_MSG_CHECKING(--with-woffdir)
+ AC_MSG_RESULT("$woffdir")
+
+ AC_SUBST(woffdir)
+fi
+
AC_ARG_ENABLE(testfont,
[AC_HELP_STRING([--enable-testfont],
[enable font generation with prefix {TTF,OTF,PS}])],
@@ -86,6 +101,7 @@ AC_ARG_ENABLE(latex,
AM_CONDITIONAL(INCLUDE_TTF,test $enable_ttf = "yes")
AM_CONDITIONAL(INCLUDE_PFB,test $enable_pfb = "yes")
AM_CONDITIONAL(INCLUDE_OTF,test $enable_otf = "yes")
+AM_CONDITIONAL(INCLUDE_WOFF,test $enable_woff = "yes")
AM_CONDITIONAL(INCLUDE_TESTFONT,test $enable_testfont = "yes")
AM_CONDITIONAL(INCLUDE_XFONTSDIR,test $enable_xfontsdir = "yes")