summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/configure.ac
diff options
context:
space:
mode:
authorVladimir Volovich <vvv@vsu.ru>2008-03-24 10:39:40 +0000
committerVladimir Volovich <vvv@vsu.ru>2008-03-24 10:39:40 +0000
commit9b4fd9b4eef2ee05aa73efb0368e36e699e238be (patch)
tree48e3fb19f82ca1b689b73a82d7fab4c1ac5f4224 /Build/source/utils/xindy/configure.ac
parentc71488d834b52bd23c9f10b510b215bfff863b5f (diff)
renamed the --with-external-clisp[=PATH] configure option to --with-clisp[=PATH]
git-svn-id: svn://tug.org/texlive/trunk@7118 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/xindy/configure.ac')
-rw-r--r--Build/source/utils/xindy/configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/Build/source/utils/xindy/configure.ac b/Build/source/utils/xindy/configure.ac
index ffe4c99bff7..17bfed52dbd 100644
--- a/Build/source/utils/xindy/configure.ac
+++ b/Build/source/utils/xindy/configure.ac
@@ -68,23 +68,23 @@ directory. I expected it to be in $srcdir/../../texk/kpathsea.
fi
AM_CONDITIONAL([TETEX_BUILD],[test "x$enable_tetex_build" = xyes])
-dnl use external or internal CLISP
-AC_ARG_WITH(external-clisp, AS_HELP_STRING([--with-external-clisp@<:@=PATH@:>@],[Use the external CLISP binary instead of re-building CLISP from source in the rte/ directory]))
+dnl location of CLISP binary
+AC_ARG_WITH(clisp, AS_HELP_STRING([--with-clisp@<:@=PATH@:>@],[Use the existing CLISP binary instead of re-building CLISP from source in the rte/ directory]))
CLISP=
-if test "x$with_external_clisp" = xyes; then
+if test "x$with_clisp" = xyes; then
AC_PATH_PROG(CLISP, clisp)
if test -z "$CLISP"; then
- AC_MSG_ERROR([--with-external-clisp specified, but clisp binary not found in PATH])
+ AC_MSG_ERROR([--with-clisp specified, but clisp binary not found in PATH])
fi
-elif test "x$with_external_clisp" = xno; then
+elif test "x$with_clisp" = xno; then
if test -d "$srcdir/rte/clisp-2.43"; then
AC_MSG_NOTICE([Using internal clisp])
else
- AC_MSG_ERROR([--without-external-clisp specified, but clisp source directory not found at $srcdir/rte/clisp-2.43])
+ AC_MSG_ERROR([--without-clisp specified, but clisp source directory not found at $srcdir/rte/clisp-2.43])
fi
-elif test -n "$with_external_clisp"; then
- CLISP="$with_external_clisp"
+elif test -n "$with_clisp"; then
+ CLISP="$with_clisp"
else
AC_PATH_PROG(CLISP, clisp)
if test -n "$CLISP"; then
@@ -104,7 +104,6 @@ if test -n "$CLISP"; then
test -f "$CLISP_LIB/clisp-link" || AC_MSG_ERROR([expected file is not found: $CLISP_LIB/clisp-link])
test -d "$CLISP_LIB/full" || AC_MSG_ERROR([expected directory is not found: $CLISP_LIB/full])
test -d "$CLISP_LIB/linkkit" || AC_MSG_ERROR([expected directory is not found: $CLISP_LIB/linkkit])
- AC_MSG_NOTICE([Using external clisp])
fi
AC_SUBST(CLISP)
AM_CONDITIONAL([EXT_CLISP], [test -n "$CLISP"])