summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/configure.ac
diff options
context:
space:
mode:
authorVladimir Volovich <vvv@vsu.ru>2008-04-06 18:53:01 +0000
committerVladimir Volovich <vvv@vsu.ru>2008-04-06 18:53:01 +0000
commit320a8db19049b2f80922143eae02c4150b66a139 (patch)
tree88db35076f3f8fe4521c650c7a29850afcf4c9a1 /Build/source/utils/xindy/configure.ac
parent70c598ad3062d542d1cf9690e26e4d687d74564e (diff)
configure.ac:
CLISP_LIB can potentially end with a backslash (on mingw), which is treated as a line merging character in Makefile, so add _AM_SUBST_NOTMAKE(CLISP_LIB) to avoid such situation, and instead refer to CLISP_LIB as @CLISP_LIB@ configure.ac, rte/Makefile.am, binaries/Makefile.am: on mingw, lisp.run is called lisp.exe on mingw, we need to use .exe suffix for the backend binary (which is called xindy.run on POSIX systems), so to avoid a clash with the frontend user command "xindy", use the name "xindy-lisp.exe" on mingw which is a counterpart of "xindy.run" on POSIX. binaries/Makefile.am: renamed XINDY_RUN to RUN_XINDY to not clash with the newly introduced XINDY_RUN and LISP_RUN variables added -norc to RUN_XINDY git-svn-id: svn://tug.org/texlive/trunk@7336 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/xindy/configure.ac')
-rw-r--r--Build/source/utils/xindy/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/Build/source/utils/xindy/configure.ac b/Build/source/utils/xindy/configure.ac
index 7789b96e0c1..d6700878921 100644
--- a/Build/source/utils/xindy/configure.ac
+++ b/Build/source/utils/xindy/configure.ac
@@ -93,6 +93,18 @@ via the --with-clisp=... option.])
fi
AC_SUBST(CLISP)
AC_SUBST(CLISP_LIB)
+dnl CLISP_LIB may end with a backslash (on mingw)
+_AM_SUBST_NOTMAKE(CLISP_LIB)
+
+if test "x$EXEEXT" = "x.exe"; then
+ XINDY_RUN=xindy-lisp.exe
+ LISP_RUN=lisp.exe
+else
+ XINDY_RUN=xindy.run
+ LISP_RUN=lisp.run
+fi
+AC_SUBST(XINDY_RUN)
+AC_SUBST(LISP_RUN)
# Checks for libraries.