summaryrefslogtreecommitdiff
path: root/Build/source/utils/texinfo/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2006-01-17 21:16:42 +0000
committerKarl Berry <karl@freefriends.org>2006-01-17 21:16:42 +0000
commita3d3111bfe26b8e5f5bc6049dfb2a4ca2edc7881 (patch)
treef4a8a34f904c1bb86adcc3ae0e14434badc6dbe4 /Build/source/utils/texinfo/Makefile.am
parent6c0eafbb1395d426a72a74538e0b2a95e8344ca6 (diff)
utils 1
git-svn-id: svn://tug.org/texlive/trunk@1484 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/texinfo/Makefile.am')
-rw-r--r--Build/source/utils/texinfo/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/Build/source/utils/texinfo/Makefile.am b/Build/source/utils/texinfo/Makefile.am
new file mode 100644
index 00000000000..9e5ffc02f29
--- /dev/null
+++ b/Build/source/utils/texinfo/Makefile.am
@@ -0,0 +1,55 @@
+# Makefile.am for texinfo.
+# $Id: Makefile.am,v 1.13 2004/12/15 16:53:59 kasal Exp $
+# Process this file with automake to produce Makefile.in in all directories.
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+# Be sure we're using the right version of Automake.
+AUTOMAKE_OPTIONS = 1.8 readme-alpha
+
+# Additional files to distribute.
+EXTRA_DIST = ChangeLog.46 INSTALL.generic INTRODUCTION README.dev \
+ config.rpath \
+ djgpp/README djgpp/config.bat djgpp/config.sed djgpp/config.site
+
+# This is to prevent texinfo.tex from being included in the top-level
+# distribution directory.
+TEXINFO_TEX = doc/texinfo.tex
+
+if TOOLS_ONLY
+ # Build native tools only.
+ SUBDIRS = lib info makeinfo util
+else
+ # All subdirectories.
+ # Do intl, m4, and lib first since the C programs depend on them.
+ # Do doc last so makeinfo will be built when we get there.
+ # Others are alphabetical.
+ SUBDIRS = $(native_tools) intl m4 lib info makeinfo po util doc
+endif
+
+# for gettext.
+ACLOCAL_AMFLAGS = -I m4
+
+# In case TEXINFO_MAINT is set during make distcheck; in this case, the
+# simple doc-related files generated in info/ make distcleancheck fail.
+distcleancheck_listfiles = \
+ find -type f -exec sh -c 'test -f $(srcdir)/{} || echo {}' ';'
+
+# One special target for installers to use by hand if desired.
+install-tex:
+ cd doc && $(MAKE) TEXMF=$(TEXMF) install-tex
+
+distclean-local:
+ -test -d "$(native_tools)" && rm -rf "$(native_tools)"
+
+# Don't install native tools for cross compile.
+if TOOLS_ONLY
+install:
+
+endif