summaryrefslogtreecommitdiff
path: root/Build/source/utils/texdoctk/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/utils/texdoctk/Makefile.am
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/texdoctk/Makefile.am')
-rw-r--r--Build/source/utils/texdoctk/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Build/source/utils/texdoctk/Makefile.am b/Build/source/utils/texdoctk/Makefile.am
new file mode 100644
index 00000000000..7b8a4a7135a
--- /dev/null
+++ b/Build/source/utils/texdoctk/Makefile.am
@@ -0,0 +1,26 @@
+## Makefile.am for the TeX Live subdirectory utils/texdoctk/
+## (In a separate directory because we hope that some day a new
+## volunteer will appear to take over this program.)
+##
+## Copyright (C) 2012-2014 Karl Berry <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+EXTRA_DIST =
+
+perl_scripts = texdoctk
+scriptsdir = texmf-dist/scripts/texdoctk
+nodist_bin_SCRIPTS =
+#
+include $(srcdir)/../../am/script_links.am
+#
+texmfdir = $(datarootdir)/$(scriptsdir)
+dist_texmf_SCRIPTS = texdoctk.pl
+
+install-data-hook: install-perl-links
+uninstall-hook: uninstall-links
+
+dist_man1_MANS = texdoctk.1
+
+CLEANFILES = $(nodist_bin_SCRIPTS)
+
+## No tests since it's unlikely builders will have Perl Tk installed.