summaryrefslogtreecommitdiff
path: root/Build/source/utils/psutils/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-20 18:13:48 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-20 18:13:48 +0000
commite5786f530f9555469c01435f86039b06aa53feba (patch)
treec868e8d32282422d7d445b729db95c3fcdafb6d0 /Build/source/utils/psutils/Makefile.am
parentebaa1768b43c8606d923d2e861b5286b74207b3e (diff)
new build system: build icu libs and xetex plus misc updates
git-svn-id: svn://tug.org/texlive/trunk@12759 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/psutils/Makefile.am')
-rw-r--r--Build/source/utils/psutils/Makefile.am101
1 files changed, 57 insertions, 44 deletions
diff --git a/Build/source/utils/psutils/Makefile.am b/Build/source/utils/psutils/Makefile.am
index 15b7b4c10dc..754a7878e0c 100644
--- a/Build/source/utils/psutils/Makefile.am
+++ b/Build/source/utils/psutils/Makefile.am
@@ -1,36 +1,10 @@
##
OS = UNIX
PAPER = a4
-CHMOD = chmod
-BINMODE = +x
AM_CPPFLAGS = -DUNIX -DPAPER=\"$(PAPER)\"
bin_PROGRAMS = epsffit psbook psnup psresize psselect pstops
-bin_SCRIPTS = getafm showchar \
- extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps \
- fixscribeps fixtpps fixwfwps fixwpps fixwwps includeres psmerge
-CLEANFILES = $(bin_SCRIPTS)
-
-PERL = /usr/bin/env perl
-MAKETEXT = $(PERL) $(srcdir)/maketext
-
-man1_MANS = epsffit.1 psbook.1 psnup.1 psresize.1 psselect.1 pstops.1 \
- getafm.1 \
- extractres.1 fixdlsrps.man fixfmps.man fixmacps.man \
- fixpsditps.man fixpspps.man fixscribeps.man fixtpps.man \
- fixwfwps.man fixwpps.man fixwwps.man includeres.man psmerge.man
-dist_man_MANS = $(man1_MANS)
-
-%: %.pl
- $(MAKETEXT) OS=$(OS) PERL="$(PERL)" $< >$@
-
-%: %.sh
- cp $< $@
- $(CHMOD) $(BINMODE) $@
-
-%.1: %.man
- $(MAKETEXT) PAPER=$(PAPER) "MAN=$(man1_MANS)" $< >$@
epsffit_SOURCES = \
config.h \
@@ -87,23 +61,63 @@ pstops_SOURCES = \
EXTRA_DIST = \
LICENSE
-# scripts.
-EXTRA_DIST += \
- getafm.sh \
- showchar.sh \
- extractres.pl \
- fixdlsrps.pl \
- fixfmps.pl \
- fixmacps.pl \
- fixpsditps.pl \
- fixpspps.pl \
- fixscribeps.pl \
- fixtpps.pl \
- fixwfwps.pl \
- fixwpps.pl \
- fixwwps.pl \
- includeres.pl \
- psmerge.pl
+perl_scripts = extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps \
+ fixscribeps fixtpps fixwfwps fixwpps fixwwps includeres psmerge
+
+shell_scripts = getafm showchar
+
+nodist_bin_SCRIPTS = $(perl_scripts)
+
+install-exec-hook:
+ @for f in $(shell_scripts); do \
+ echo "$(INSTALL_SCRIPT) '$(srcdir)/$$f.sh' '$(DESTDIR)$(bindir)/$$f'"; \
+ $(INSTALL_SCRIPT) "$(srcdir)/$$f.sh" "$(DESTDIR)$(bindir)/$$f"; \
+ done
+
+uninstall-hook:
+ @for f in $(shell_scripts); do \
+ echo "rm -f '$(DESTDIR)$(bindir)/$$f'"; \
+ rm -f "$(DESTDIR)$(bindir)/$$f"; \
+ done
+
+dist_man1_MANS = \
+ fixdlsrps.man \
+ fixfmps.man \
+ fixmacps.man \
+ fixpsditps.man \
+ fixpspps.man \
+ fixscribeps.man \
+ fixtpps.man \
+ fixwfwps.man \
+ fixwpps.man \
+ fixwwps.man \
+ getafm.man \
+ includeres.man \
+ psmerge.man
+
+nodist_man1_MANS = \
+ epsffit.1\
+ extractres.1 \
+ psbook.1 \
+ psnup.1 \
+ psresize.1 \
+ psselect.1 \
+ pstops.1
+
+EXTRA_DIST += $(perl_scripts:=.pl) $(shell_scripts:=.sh) $(nodist_man1_MANS:.1=.man)
+
+CLEANFILES = $(nodist_bin_SCRIPTS) $(nodist_man1_MANS)
+
+PERL = /usr/bin/env perl
+MAKETEXT = $(PERL) $(srcdir)/maketext
+
+EXTRA_DIST += maketext
+
+%: %.pl
+ $(MAKETEXT) OS=$(OS) PERL="$(PERL)" $< >$@
+
+%.1: %.man
+ $(MAKETEXT) PAPER=$(PAPER) "MAN=$(man1_MANS)" $< >$@
## Not used
##
@@ -116,7 +130,6 @@ EXTRA_DIST += \
Makefile.unix \
Makefile.wat \
descrip.mms \
- maketext \
md68_0.ps \
md71_0.ps