summaryrefslogtreecommitdiff
path: root/Build/source/utils/ps2eps/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/utils/ps2eps/Makefile.am
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/ps2eps/Makefile.am')
-rw-r--r--Build/source/utils/ps2eps/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/Build/source/utils/ps2eps/Makefile.am b/Build/source/utils/ps2eps/Makefile.am
new file mode 100644
index 00000000000..e940fc1dceb
--- /dev/null
+++ b/Build/source/utils/ps2eps/Makefile.am
@@ -0,0 +1,52 @@
+## $Id$
+## Makefile.am for the TeX Live subdirectory utils/ps2eps/
+##
+## Copyright 2017 Karl Berry <tex-live@tug.org>
+## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+
+## We want to re-distribute the whole original ps2eps source tree.
+EXTRA_DIST = $(PS2EPS_TREE)
+
+## Patches applied to the original source tree
+EXTRA_DIST += TLpatches
+
+# Files not to be distributed
+include $(srcdir)/../../am/dist_hook.am
+NEVER_NAMES += $(NEVER_NAMES_SUB)
+
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = bbox
+
+bbox_SOURCES = \
+ @PS2EPS_TREE@/src/C/bbox.c
+
+man1_MANS = \
+ $(PS2EPS_TREE)/doc/man/man1/bbox.1 \
+ $(PS2EPS_TREE)/doc/man/man1/ps2eps.1
+
+perl_scripts = ps2eps
+scriptsdir = texmf-dist/scripts/ps2eps
+nodist_bin_SCRIPTS =
+
+include $(srcdir)/../../am/script_links.am
+
+texmfdir = $(datarootdir)/$(scriptsdir)
+nodist_texmf_SCRIPTS = $(PS2EPS_TREE)/bin/ps2eps.pl
+
+install-data-hook: install-perl-links
+uninstall-hook: uninstall-links
+
+CLEANFILES = $(nodist_bin_SCRIPTS)
+
+## Tests
+##
+TESTS = bbox.test
+EXTRA_DIST += $(TESTS)
+bbox.log: bbox$(EXEEXT)
+
+## bbox.test
+EXTRA_DIST += tests/plot.pbm tests/plot.out
+DISTCLEANFILES = plot.out
+