summaryrefslogtreecommitdiff
path: root/Build/source/utils/devnag/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-12-23 09:31:54 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-12-23 09:31:54 +0000
commit8d3ce9fe901a849229c872bf394f06c5a10fd610 (patch)
tree84bc147e76474cb8f75520f128466a7e48949800 /Build/source/utils/devnag/Makefile.am
parentf6a13636e23f23b45cc27926fd3efda17535565e (diff)
Move texk/devnag => utils/devnag
git-svn-id: svn://tug.org/texlive/trunk@35886 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/devnag/Makefile.am')
-rw-r--r--Build/source/utils/devnag/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Build/source/utils/devnag/Makefile.am b/Build/source/utils/devnag/Makefile.am
new file mode 100644
index 00000000000..9a17e26a6f6
--- /dev/null
+++ b/Build/source/utils/devnag/Makefile.am
@@ -0,0 +1,34 @@
+## Makefile.am for the TeX Live subdirectory utils/devnag/
+##
+## Copyright 2009-2014 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+AM_CPPFLAGS = -DTEXLIVE
+
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = devnag
+
+devnag_SOURCES = src/devnag.c
+
+$(devnag_OBJECTS): config.force
+
+config.force: $(KPATHSEA_DEPEND)
+ echo timestamp >config.force
+ $(SHELL) ./config.status --recheck
+
+DISTCLEANFILES = config.force
+
+## Tests.
+##
+TESTS = tests/devnag.test
+EXTRA_DIST = $(TESTS)
+## tests/devnag.test
+EXTRA_DIST += \
+ tests/captions.dn tests/captions.tex \
+ tests/examples.dn tests/examples.tex \
+ tests/misspaal.dn tests/misspaal.tex \
+ tests/vedasample.dn tests/vedasample.tex
+
+DISTCLEANFILES += captions.dn examples.dn *.tex
+