summaryrefslogtreecommitdiff
path: root/Build/source/utils/asymptote/configure.ac
diff options
context:
space:
mode:
authorNorbert Preining <preining@logic.at>2018-04-06 05:21:01 +0000
committerNorbert Preining <preining@logic.at>2018-04-06 05:21:01 +0000
commita11ba95f5b305c7d01cf2b6aec5640a6b1831117 (patch)
tree028e9aa29fb00177617b77a8d804a7bce694d5b0 /Build/source/utils/asymptote/configure.ac
parent0de24c07adcc80181a7aee919e1316a6149dda56 (diff)
asymptote 2.43
git-svn-id: svn://tug.org/texlive/trunk@47319 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/asymptote/configure.ac')
-rw-r--r--Build/source/utils/asymptote/configure.ac23
1 files changed, 19 insertions, 4 deletions
diff --git a/Build/source/utils/asymptote/configure.ac b/Build/source/utils/asymptote/configure.ac
index 924f35422ca..e2332bce521 100644
--- a/Build/source/utils/asymptote/configure.ac
+++ b/Build/source/utils/asymptote/configure.ac
@@ -3,16 +3,17 @@
# this file.
AC_PREREQ(2)
-AC_INIT([Asymptote],[2.42],[http://sourceforge.net/projects/asymptote])
+AC_INIT([Asymptote],[2.43],[http://sourceforge.net/projects/asymptote])
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
m4_include([ax_pthread.m4])
-test "$CXXFLAGS" || CXXFLAGS=""
+test "$CXXFLAGS" || CXXFLAGS="-std=c++11"
test "$CFLAGS" || CFLAGS="-g -O3"
AC_C_BIGENDIAN
+AC_CANONICAL_HOST
test "$prefix" = NONE && prefix=/usr/local
Datadir=$datadir
@@ -123,8 +124,22 @@ AC_CHECK_HEADER(unordered_map,AC_DEFINE(HAVE_UNORDERED_MAP,1,
[Define to 1 if you have tr1/unordered_map]),
[AC_CHECK_HEADER(ext/hash_map,,OPTIONS=$OPTIONS"-DNOHASH ")])])
-GCVERSION=7.6.2
-ATOMICVERSION=7.6.2
+case $host in
+ *mac*) HELLO_SYSTEM='hello-linux.$(OBJEXT)' ;;
+ *) HELLO_SYSTEM='hello-generic.$(OBJEXT)' ;;
+esac
+
+case "${host_os}" in
+ darwin*)
+ GCVERSION=7.6.0
+ ATOMICVERSION=7.6.0
+ ;;
+ *)
+ GCVERSION=7.6.2
+ ATOMICVERSION=7.6.2
+ ;;
+esac
+
GCFILE=gc-$GCVERSION
ac_cv_use_gc="system"