summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvipdfmx/src/Makefile.am
diff options
context:
space:
mode:
authorJonathan Kew <jfkthame@googlemail.com>2006-09-29 15:15:10 +0000
committerJonathan Kew <jfkthame@googlemail.com>2006-09-29 15:15:10 +0000
commit387cf3625583fb046baf756f72f188924f35cfe2 (patch)
tree6e09f2e03b9c590a9f14689dfdb4d77ed66e773d /Build/source/texk/xdvipdfmx/src/Makefile.am
parentfe77ff4cdab25604b424a273c726920830f63abc (diff)
adding xdvipdfmx sources
git-svn-id: svn://tug.org/texlive/trunk@2220 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvipdfmx/src/Makefile.am')
-rw-r--r--Build/source/texk/xdvipdfmx/src/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/Build/source/texk/xdvipdfmx/src/Makefile.am b/Build/source/texk/xdvipdfmx/src/Makefile.am
new file mode 100644
index 00000000000..7fa8533d8e0
--- /dev/null
+++ b/Build/source/texk/xdvipdfmx/src/Makefile.am
@@ -0,0 +1,45 @@
+bin_PROGRAMS = xdvipdfmx
+xdvipdfmx_SOURCES = agl.c agl_standard.c bmpimage.c cff.c cff_dict.c cid.c cidtype0.c cidtype2.c \
+cmap.c cmap_read.c cmap_write.c cs_type2.c \
+dpxconf.c dpxcrypt.c dpxfile.c dpxutil.c \
+dvi.c dvipdfmx.c epdf.c error.c fontmap.c jpegimage.c mem.c mfileio.c mpost.c \
+numbers.c otl_conf.c otl_opt.c pdfcolor.c pdfdev.c pdfdoc.c pdfdraw.c pdfencoding.c \
+pdfencrypt.c pdffont.c pdfnames.c pdfobj.c pdfparse.c pdfresource.c pdfximage.c \
+pkfont.c pngimage.c pst.c pst_obj.c sfnt.c \
+spc_color.c spc_dvips.c spc_html.c spc_misc.c spc_pdfm.c spc_tpic.c spc_util.c spc_xtx.c specials.c \
+subfont.c tfm.c \
+tt_aux.c tt_cmap.c tt_glyf.c tt_gsub.c tt_post.c tt_table.c truetype.c \
+type0.c t1_char.c t1_load.c type1.c type1c.c \
+unicode.c vf.c \
+agl.h bmpimage.h asl_charset.h cff.h cff_dict.h cff_limits.h cff_stdstr.h cff_types.h \
+cid.h cid_basefont.h cid_p.h cidtype0.h cidtype2.h cmap.h cmap_p.h cmap_read.h cmap_write.h \
+cs_type2.h dpxconf.h dpxcrypt.h dpxutil.h dpxfile.h dvi.h dvicodes.h epdf.h error.h fontmap.h \
+jpegimage.h mem.h mfileio.h mpost.h numbers.h otl_conf.h otl_opt.h pdfcolor.h pdfdev.h \
+pdfdoc.h pdfdraw.h pdfencoding.h pdfencrypt.h pdffont.h pdflimits.h pdfnames.h pdfobj.h \
+pdfparse.h pdfresource.h pdfximage.h pkfont.h pngimage.h pst.h pst_obj.h sfnt.h \
+spc_color.h spc_dvips.h spc_html.h spc_misc.h spc_pdfm.h spc_tpic.h spc_util.h spc_xtx.h specials.h \
+subfont.h system.h tfm.h \
+tt_aux.h tt_cmap.h tt_glyf.h tt_gsub.h tt_post.h tt_table.h truetype.h \
+type0.h t1_char.h t1_load.h type1.h type1c.h \
+unicode.h vf.h
+
+
+LIBPNGDIR=$(top_builddir)/../../libs/libpng
+LIBPNGSRCDIR=$(srcdir)/$(LIBPNGDIR)
+LIBPNGDEP = @LIBPNGDEP@
+LDLIBPNG = @LDLIBPNG@
+
+ZLIBDIR=$(top_builddir)/../../libs/zlib
+ZLIBSRCDIR=$(srcdir)/$(ZLIBDIR)
+ZLIBDEP = @ZLIBDEP@
+LDZLIB = @LDZLIB@
+
+FREETYPE2DIR = $(top_builddir)/../../libs/freetype2
+FREETYPE2SRCDIR = $(srcdir)/$(FREETYPE2DIR)
+LDFREETYPE2 = @LDFREETYPE2@
+FREETYPE2DEP = @FREETYPE2DEP@
+
+xdvipdfmx_CPPFLAGS = @LIBPNGCPPFLAGS@ @ZLIBCPPFLAGS@ @FREETYPE2CPPFLAGS@
+xdvipdfmx_LDADD = $(LDADD) $(LDLIBPNG) $(LDZLIB) $(LDFREETYPE2)
+xdvipdfmx_DEPENDENCIES = $(ZLIBDEP) $(LIBPNGDEP) $(FREETYPE2DEP)
+xdvipdfmx_LDFLAGS = @xdvipdfmx_LDFLAGS@