summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvipdfmx/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-25 08:58:23 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-25 08:58:23 +0000
commitb50e8d78f4b4b86177863a60bc85f5cd393ba04b (patch)
tree0819fc02385b631cb47eaa46cc3613613e64ceef /Build/source/texk/xdvipdfmx/configure.ac
parent622523bd36859ef50591a5e4696bf803ca30a87d (diff)
better handling of fontconfig, using pkg-config
git-svn-id: svn://tug.org/texlive/trunk@13457 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvipdfmx/configure.ac')
-rw-r--r--Build/source/texk/xdvipdfmx/configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/Build/source/texk/xdvipdfmx/configure.ac b/Build/source/texk/xdvipdfmx/configure.ac
index db6fd5ee46e..d021e90c2b7 100644
--- a/Build/source/texk/xdvipdfmx/configure.ac
+++ b/Build/source/texk/xdvipdfmx/configure.ac
@@ -74,14 +74,15 @@ fi
dnl Check for additional libraries.
KPSE_CHECK_FRAMEWORK([ApplicationServices], [ATSFontRef fontRef])
-
+KPSE_FONTCONFIG_FLAGS
if test "x$kpse_cv_have_ApplicationServices" = xyes; then
build=yes
AC_DEFINE([XETEX_MAC], 1, [Define if part of a teTeX/TeX Live build for Mac OS X.])
- LIBS="$LIBS -framework ApplicationServices"
else
+ KPSE_ADD_FLAGS([fontconfig])
CHO_CHECK_LIBFONTCONFIG
- build=$have_libfontconfig
+ KPSE_RESTORE_FLAGS
+ build=$cho_cv_have_fontconfig
fi
if test "x$build" = xyes; then
@@ -93,6 +94,7 @@ or the fontconfig library (on other platforms) to be available, otherwise it
cannot support XeTeX output using standard system-installed fonts.])
fi
AM_CONDITIONAL([build], [test "x$build" = xyes])
+AM_CONDITIONAL([build_MacOsX], [test "x$kpse_cv_have_ApplicationServices" = xyes])
AC_CONFIG_FILES([Makefile src/Makefile])