summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvik/tests/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-21 09:44:45 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-21 09:44:45 +0000
commitb77e78eaf3652b80e78ae80f770bd3bdf721363d (patch)
treed3c67296e30534c63d02c5bb5e5790b1d9150cd0 /Build/source/texk/xdvik/tests/Makefile.am
parentad04e2284cbf8d1a4b268636c7451f89d29c4d0a (diff)
new build system: mode texk/xdvik and general update
git-svn-id: svn://tug.org/texlive/trunk@12771 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvik/tests/Makefile.am')
-rw-r--r--Build/source/texk/xdvik/tests/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Build/source/texk/xdvik/tests/Makefile.am b/Build/source/texk/xdvik/tests/Makefile.am
new file mode 100644
index 00000000000..4fb76fddb7b
--- /dev/null
+++ b/Build/source/texk/xdvik/tests/Makefile.am
@@ -0,0 +1,35 @@
+## Makefile.am for the TeX Live subdirectory texk/xdvik/tests/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+include ../common.am
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/gui $(common_includes)
+
+check_PROGRAMS = run_tests
+
+TESTS = $(check_PROGRAMS)
+
+run_tests_SOURCES = \
+ run_tests.c \
+ run_tests.h \
+ test_dl_list.c \
+ test_string_list.c \
+ test_string_utils.c \
+ test_util.c
+
+run_tests_DEPENDENCIES = ../libxdvi.a ../gui/libgui.a $(common_dependencies)
+
+LDADD = ../libxdvi.a ../gui/libgui.a $(common_ldadd)
+
+../libxdvi.a: $(libxdvi_dependencies)
+ cd .. && $(MAKE) $(AM_MAKEFLAGS) libxdvi.a
+
+../gui/libgui.a: $(libgui_dependencies)
+ cd ../gui && $(MAKE) $(AM_MAKEFLAGS) libgui.a
+
+## Not used
+##
+EXTRA_DIST = test1.c
+