summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvik/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:28:49 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:28:49 +0000
commit64fd18cbb2e8fb3ed44dd20ee3d0cced7fa1a5c2 (patch)
tree256fdc8938df0a0fa1b7f167567d0660aa9e232f /Build/source/texk/xdvik/configure.ac
parentdd3e4c3b3688ba6289553b06af392e42123eb76e (diff)
towards TL2010: texk/xdvik
git-svn-id: svn://tug.org/texlive/trunk@15967 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvik/configure.ac')
-rw-r--r--Build/source/texk/xdvik/configure.ac19
1 files changed, 13 insertions, 6 deletions
diff --git a/Build/source/texk/xdvik/configure.ac b/Build/source/texk/xdvik/configure.ac
index 5fea1bfcf8c..4275b2cc32c 100644
--- a/Build/source/texk/xdvik/configure.ac
+++ b/Build/source/texk/xdvik/configure.ac
@@ -15,6 +15,7 @@ AC_CONFIG_MACRO_DIR([../../m4])
dnl Common code for all programs using libkpathsea.
KPSE_COMMON([xdvik])
+KPSE_CANONICAL_HOST
dnl Include additional code for xdvik.
m4_include([ac/xdvik.ac])
@@ -29,7 +30,7 @@ AS_CASE([$with_ps],
[no], [PS_DEF=],
[dps], [PS_DEF=-DPS_DPS],
[news], [PS_DEF=-DPS_NEWS],
- [KPSE_MSG_WARN([unknown--with-ps argument `$with_ps'; using gs.])
+ [AC_MSG_WARN([unknown--with-ps argument `$with_ps'; using gs.])
PS_DEF=-DPS_GS])
AC_SUBST([PS_DEF])
@@ -193,6 +194,8 @@ AC_CHECK_LIB([Xp], [XpQueryVersion],
[x_xp_lib='-lXp'], [],
[$x_ext_lib -lX11 $X_EXTRA_LIBS $XLFLAG])
+if test "x$enable_build" != xno || test -f config.force; then
+
# Check which toolkit was specified
AS_CASE([$with_xdvi_x_toolkit],
[next | nextaw | neXtaw], [val=neXtaw],
@@ -200,7 +203,7 @@ AS_CASE([$with_xdvi_x_toolkit],
["" | x | xa | xaw], [val=xaw],
[y | ye | yes], [val=yes],
[m | mo | mot | moti | motif], [val=motif],
- [KPSE_MSG_WARN([unknown --with-xdvi-x-toolkit argument
+ [AC_MSG_WARN([unknown --with-xdvi-x-toolkit argument
`$with_xdvi_x_toolkit'; using xaw.])
val=xaw])
with_xdvi_x_toolkit=$val
@@ -269,12 +272,16 @@ KPSE_T1LIB_FLAGS
KPSE_ADD_FLAGS([kpathsea])
-KPSE_CHECK_KPSE_FORMAT([enc], ,
- [KPSE_MSG_ERROR([xdvik],
- [your kpathsea has no kpse_enc_format.])])
+KPSE_CHECK_KPSE_FORMAT([enc], [],
+ [AC_MSG_ERROR([your kpathsea has no kpse_enc_format.])])
+AC_CHECK_HEADER([kpathsea/version.h], [],
+ [AC_MSG_ERROR([Sorry, kpathsea too old])])
KPSE_RESTORE_FLAGS
+echo timestamp >config.force
+fi
+
AC_ARG_WITH([default-dvips-path],
AS_HELP_STRING([--with-default-dvips-path=CMD],
[Use CMD as default DVI to PS converter]), ,
@@ -302,7 +309,7 @@ dnl The subdirectory squeeze must be configured for the build system.
dnl When cross compiling, can not share the cache file with the subdirectory!
AC_CONFIG_COMMANDS_POST([AS_IF([test "x$cross_compiling" = xyes],
[cache_file=/dev/null
- ac_configure_args="$ac_configure_args --host='$build' \
+ ac_configure_args="$ac_configure_args --host='$kpse_build_alias' \
CC='$BUILDCC' CPPFLAGS='$BUILDCPPFLAGS'\
CFLAGS='$BUILDCFLAGS' LDFLAGS='$BUILDLDFLAGS'"])])