summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvik/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-30 14:03:03 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-30 14:03:03 +0000
commit2587581c41ae254fc09eb6a940b97e53d862fa3e (patch)
tree0ac5fcb149cd3c89813a972344788dabb7337140 /Build/source/texk/xdvik/configure.ac
parent0fc1858e50775d7e90bc60bed198934f72e72046 (diff)
new build system: update for texk/xdvik/
git-svn-id: svn://tug.org/texlive/trunk@12895 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvik/configure.ac')
-rw-r--r--Build/source/texk/xdvik/configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/Build/source/texk/xdvik/configure.ac b/Build/source/texk/xdvik/configure.ac
index 7ee579d0554..9eb7050ac0b 100644
--- a/Build/source/texk/xdvik/configure.ac
+++ b/Build/source/texk/xdvik/configure.ac
@@ -171,13 +171,7 @@ fi
# Check whether -lXpm can be used
XDVI_FIND_XPM
-# Check for libXext and libXp.
-# Although libXp is now defunct (no longer part of XOrg), older versions
-# of libXm may need to include libXp. Same for the equally defunct libXaw8.
-# We certainly don't want to include libXp unless necessay,this would just
-# perpetuate the need to keep libXp.so around. Moreover for ELF shared
-# libraries the need for libXp is probably encoded into libXm.so and/or
-# libXaw.so and need not to be specified explicitly.
+# Check for libXext.
AS_IF([test -n "$x_libraries"],
[XLFLAG="-L$x_libraries"],
[XLFLAG=])
@@ -185,12 +179,20 @@ if test -z "$x_ext_lib"; then # allow envvar override
AC_CHECK_LIB([Xext], [XextCreateExtension],
[x_ext_lib='-lXext'], [],
[-lX11 $X_EXTRA_LIBS $XLFLAG])
- AC_CHECK_LIB([Xp], [XpQueryVersion],
- [x_xp_lib='-lXp'], [],
- [$x_ext_lib -lX11 $X_EXTRA_LIBS $XLFLAG])
fi
AC_SUBST([x_ext_lib])
+# Check for libXp.
+# Although libXp is now defunct (no longer part of XOrg), older versions
+# of libXm may need to link with libXp; same for the equally defunct libXaw8.
+# We certainly don't want to include libXp unless necessay, since this might
+# only perpetuate the need to keep libXp.so around.
+# Moreover for ELF shared libraries a requirement for libXp.so is probably
+# encoded into libXm.so and/or libXaw.so and need not be specified explicitly.
+AC_CHECK_LIB([Xp], [XpQueryVersion],
+ [x_xp_lib='-lXp'], [],
+ [$x_ext_lib -lX11 $X_EXTRA_LIBS $XLFLAG])
+
# Check which toolkit was specified
AS_CASE([$with_xdvi_x_toolkit],
[next | nextaw | neXtaw], [val=neXtaw],
@@ -210,7 +212,7 @@ elif test "x$with_xdvi_x_toolkit" = xneXtaw; then
prog_extension="nextaw"
x_tool_libs="-lneXtaw"
else
- # Check for Xaw headers
+ # Check for Xaw headers and library version
XDVI_CHECK_XAW_HEADERS
if test "x$with_xdvi_x_toolkit" != xxaw; then
if test "x$with_xdvi_x_toolkit" = xmotif; then