summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvik/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-25 10:27:56 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-25 10:27:56 +0000
commit14fdf58582eb34614c899048041260830bf11319 (patch)
tree24c257e172a5759d4653886820e0debc19a79e75 /Build/source/texk/xdvik/configure.ac
parent1d49a87a191295313dd1fdbce07dfb18ddd65bfc (diff)
new build system: update
git-svn-id: svn://tug.org/texlive/trunk@12515 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvik/configure.ac')
-rw-r--r--Build/source/texk/xdvik/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/Build/source/texk/xdvik/configure.ac b/Build/source/texk/xdvik/configure.ac
new file mode 100644
index 00000000000..f43fd506c7d
--- /dev/null
+++ b/Build/source/texk/xdvik/configure.ac
@@ -0,0 +1,29 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_define([xdvik_version], [22.84.14])
+AC_INIT([xdvik for TeX Live], xdvik_version, [tex-k@tug.org])
+AC_PREREQ([2.63])
+AC_CONFIG_SRCDIR([xdvi.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([xdvik])
+
+AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
+
+KPSE_KPATHSEA_FLAGS
+KPSE_T1LIB_FLAGS
+
+XDVIK_VERSION=xdvik_version
+AC_SUBST([XDVIK_VERSION])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT