summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/otps/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:27:09 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:27:09 +0000
commit5e8e9500102800e68c9e7fcac9e85c1668b71a36 (patch)
tree81d79ac70ffbb127e8063f18c8f55475ca169ee1 /Build/source/texk/web2c/otps/Makefile.am
parente6a9c88ada2f11dd61e4c4e39dff84944bed5787 (diff)
towards TL2010: texk/web2c
git-svn-id: svn://tug.org/texlive/trunk@15964 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/otps/Makefile.am')
-rw-r--r--Build/source/texk/web2c/otps/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/Build/source/texk/web2c/otps/Makefile.am b/Build/source/texk/web2c/otps/Makefile.am
index 1ed55c05a32..d55b87b861d 100644
--- a/Build/source/texk/web2c/otps/Makefile.am
+++ b/Build/source/texk/web2c/otps/Makefile.am
@@ -9,12 +9,8 @@ AM_YFLAGS = -d -v
proglib = ../lib/lib.a
-# Automake automatically uses $(proglib)=../lib/lib.a as dependency.
-# This does not work for the configure substitution $(KPATHSEA_LIBS),
-# thus we let $(proglib) artificially depend on $(KPATHSEA_LIBS).
-
# Rebuild $(proglib)
-$(proglib): $(KPATHSEA_DEPEND) ${top_srcdir}/lib/*.c
+$(proglib): ${top_srcdir}/lib/*.c
cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
## Rebuild libkpathsea
@@ -28,6 +24,7 @@ noinst_HEADERS = otp.h routines.h yystype.h
if OTANGLE
bin_PROGRAMS = $(otps_programs)
bin_SCRIPTS = $(otps_scripts)
+dist_man1_MANS = $(otps_programs:=.man) $(otps_scripts:=.man)
endif OTANGLE
EXTRA_PROGRAMS = $(otps_programs)
@@ -45,6 +42,8 @@ outocp_SOURCES = \
outocp.c
LDADD = $(proglib) $(KPATHSEA_LIBS)
+otp2ocp_DEPENDENCIES = $(proglib) $(KPATHSEA_DEPEND)
+outocp_DEPENDENCIES = $(proglib) $(KPATHSEA_DEPEND)
## Tests
##