summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2019-06-26 16:09:52 +0000
committerKarl Berry <karl@freefriends.org>2019-06-26 16:09:52 +0000
commite8cdab59f1d33c0138e65e9c2fc327e98aa4cec7 (patch)
tree6f9f7168b90d31ac0df13d6692ca5e0e36090224 /Build/source/texk/web2c/configure.ac
parent231b1783253e75f1196dd7b0402879e5ada1692d (diff)
omit icu test from harfbuzz test
git-svn-id: svn://tug.org/texlive/trunk@51470 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac21
1 files changed, 15 insertions, 6 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 8a6808c3de1..d7e5be5ac88 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -1,7 +1,7 @@
dnl $Id$
dnl Process this file with Autoconf to produce a configure script for Web2c.
dnl
-dnl Copyright 2018 Karl Berry <tex-live@tug.org>
+dnl Copyright 2018-2019 Karl Berry <tex-live@tug.org>
dnl Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
@@ -98,7 +98,7 @@ if test "x$enable_ipc" = xyes; then
AC_DEFINE([IPC], 1, [tex: Define to enable --ipc.])
fi
-# We may need additional libraries for luaTeX.
+# We may need additional libraries for LuaTeX.
# On Solaris -lnsl for gethostbyname(), -lrt for nanosleep(),
# and maybe -lresolv for inet_aton().
lua_socketlibs=$socketlibs
@@ -263,9 +263,18 @@ KPSE_POPPLER_FLAGS
KPSE_XPDF_FLAGS
KPSE_ZZIPLIB_FLAGS
KPSE_TECKIT_FLAGS
-KPSE_ICU_FLAGS
-KPSE_HARFBUZZ_FLAGS
-KPSE_GRAPHITE2_FLAGS
+
+# LuaTeX and XeTeX need harfbuzz.
+if test "x$enable_xetex" = xyes \
+ || test "x$enable_luatex" = xyes || test "x$enable_luatex53" = xyes; then
+ KPSE_HARFBUZZ_FLAGS
+fi # end xetex/luatex for harfbuzz
+
+# XeTeX, but not LuaTeX, needs icu and graphite.
+if test "x$enable_xetex" = xyes; then
+ KPSE_ICU_FLAGS
+ KPSE_GRAPHITE2_FLAGS
+fi # end xetex for icu/graphite
# Check size of off_t (using <kpathsea/config.h>)
KPSE_ADD_FLAGS([kpathsea])
@@ -343,7 +352,7 @@ AH_TOP([/* w2c/c-auto.h: defines for web2c, as determined by configure.
#define WEB2CVERSION "REPLACE-WITH-WEB2CVERSION"])
AH_BOTTOM([#endif /* !WEB2C_C_AUTO_H */])
-dnl Additional config header for luaTeX
+dnl Additional config header for LuaTeX
AC_CONFIG_HEADERS([ff-config.h:luatexdir/luafontloader/ff-config.in])
# For cross-compilation. Put at the end so there is a fair chance