summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-06-28 10:28:44 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-06-28 10:28:44 +0000
commit2cbe0517df9daa71a49132982036b5c120e472fd (patch)
treec02ad3ca612f852c77a62c90b5105727255a1b44 /Build/source/texk/web2c/configure.ac
parentd6f28a4f2581a1e325dd3e8e3f2fa322b0785412 (diff)
texk/web2c: Build fix for libsynctex - the SyncTeX parser library
git-svn-id: svn://tug.org/texlive/trunk@34467 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 06b0f4befa9..34788c9c681 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -33,6 +33,12 @@ AC_CONFIG_MACRO_DIRS([../../m4 m4])
WEB2CVERSION=tex_live_version()
AC_SUBST([WEB2CVERSION])
+dnl Building a shared libsynctex requires a system zlib
+if test "x$enable_shared:$with_system_zlib" = xyes:no; then
+ enable_shared=no
+ ac_configure_args="$ac_configure_args '--disable-shared'"
+fi
+
dnl Common code for all programs using libkpathsea.
KPSE_COMMON([web2c programs])
@@ -388,6 +394,8 @@ AC_CONFIG_FILES([silent-sh], [chmod +x silent-sh])
m4_define([synctex_version], m4_chomp(m4_include([synctexdir/synctex_parser_version.txt]))[.0])
AC_SUBST([SYNCTEXVERSION], [synctex_version])
KPSE_LT_VERSION([synctex])
+AS_IF([test "x$enable_synctex" != xno],
+ [AC_SUBST([WANTEDLIBS], [libsynctex.la])])
AC_CONFIG_FILES([synctexdir/synctex.pc])