summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-07-15 15:46:02 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-07-15 15:46:02 +0000
commite4042723eabd6f9efb9b68034395b7d0ea999b82 (patch)
tree4e6d6da912c4eacb83aad667d10f7827643f53f9 /Build/source/texk/web2c/configure.ac
parente8b6183a1df246ebab704b4bc737a10fe08051da (diff)
LuaTeX: Distinguish poppler >= 0.25 or <= 0.24
git-svn-id: svn://tug.org/texlive/trunk@34619 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 4e81dba929c..d65475db817 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -287,6 +287,24 @@ KPSE_ADD_FLAGS([kpathsea])
AC_CHECK_SIZEOF([off_t], , AC_INCLUDES_DEFAULT
[#include <kpathsea/config.h>])
+# Check of poppler 0.25 or better
+KPSE_ADD_FLAGS([poppler])
+AC_CACHE_CHECK([for StructTreeRoot.h (poppler 0.25 or better)],
+ [kpse_cv_have_StructTreeRoot_h],
+ [dnl
+AC_LANG_PUSH([C++])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>
+#include <StructTreeRoot.h>]],
+ [[PDFDoc *doc;
+ Dict *dict;
+ StructTreeRoot root(doc, dict);]])],
+ [kpse_cv_have_StructTreeRoot_h=yes],
+ [kpse_cv_have_StructTreeRoot_h=no])
+AC_LANG_POP([C++])])
+if test "x$kpse_cv_have_StructTreeRoot_h" = xyes; then
+ AC_DEFINE([HAVE_STRUCTTREEROOT_H], 1,
+ [Define to 1 if you have the <StructTreeRoot.h> header file.])
+fi
KPSE_RESTORE_FLAGS
dnl Write output here, instead of putting a zillion -D's on the command line.