summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2015-09-02 07:02:00 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2015-09-02 07:02:00 +0000
commitffe0571cfeed11aff6873c2a6337b678f06cac11 (patch)
treeb1fee9844b8308ad9ff91a66d2684d97bc0b240f /Build/source/texk/web2c/configure.ac
parentd67729aa4d5897be113d62b655d4b63173a918fa (diff)
luaTeX: Remove all g++ warnings
git-svn-id: svn://tug.org/texlive/trunk@38274 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index cc52b7cc7ff..c6cd65893fe 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -283,6 +283,22 @@ else
KPATHSEA_PATHS_H='${top_builddir}/..'
fi
AC_SUBST([KPATHSEA_PATHS_H])
+
+dnl Check for Object::initCmd(const char *) etc
+KPSE_ADD_FLAGS([poppler])
+AC_LANG_PUSH([C++])
+AC_MSG_CHECKING([for Object::[initCmd(const char*)] etc])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <Object.h>]],
+ [[Object *obj; const char *name;
+obj->initCmd(name)->isStream(name);]])],
+ [kpse_cv_have_Object_initCmd_const_charp=yes],
+ [kpse_cv_have_Object_initCmd_const_charp=no])
+AC_MSG_RESULT([$kpse_cv_have_Object_initCmd_const_charp])
+AC_LANG_POP([C++])
+if test "x$kpse_cv_have_Object_initCmd_const_charp" = xyes; then
+ AC_DEFINE([HAVE_OBJECT_INITCMD_CONST_CHARP], 1,
+ [Define to 1 if you have the `Object::initCmd(const char*)' function.])
+fi
KPSE_RESTORE_FLAGS
dnl Write output here, instead of putting a zillion -D's on the command line.