summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-10-06 14:31:58 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-10-06 14:31:58 +0000
commit2117406b11792e5a361dc853c0656b63366c10a8 (patch)
treefd2933ce2ddbf0349e31bb4ad02af2db1ba4418a /Build/source/texk/web2c/configure.ac
parentadd36363c1ac31e2e51925e69275c4dbdf26401f (diff)
Allow to build luaTeX with (installed) poppler-0.18.0
git-svn-id: svn://tug.org/texlive/trunk@24218 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 7fa4163b377..f97caba635b 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -272,6 +272,48 @@ KPSE_TECKIT_FLAGS
KPSE_ICU_XETEX_FLAGS([icule])
KPSE_OBSDCOMPAT_FLAGS
+# Checks for xpdf poppler features.
+KPSE_ADD_FLAGS([poppler])
+AC_LANG_PUSH([C++])
+AC_CACHE_CHECK([for Annot::decRefCnt],
+ [kpse_cv_have_Annot_decRefCnt],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <goo/GooString.h>
+#include <Object.h>
+#include <Array.h>
+#include <Annot.h>]],
+ [[Annot *an; an->decRefCnt();]])],
+ [kpse_cv_have_Annot_decRefCnt=yes],
+ [kpse_cv_have_Annot_decRefCnt=no])])
+AS_IF([test "x$kpse_cv_have_Annot_decRefCnt" = xyes],
+ [AC_DEFINE([HAVE_ANNOTDECREFCNT], 1,
+ [Define to 1 if class `Annot' has the `decRefCnt' member.])])
+AC_CACHE_CHECK([for class AnnotBorderStyle],
+ [kpse_cv_have_AnnotBorderStyle],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <goo/GooString.h>
+#include <Object.h>
+#include <Array.h>
+#include <Annot.h>]],
+ [[AnnotBorderStyle *an;]])],
+ [kpse_cv_have_AnnotBorderStyle=yes],
+ [kpse_cv_have_AnnotBorderStyle=no])])
+AS_IF([test "x$kpse_cv_have_AnnotBorderStyle" = xyes],
+ [AC_DEFINE([HAVE_ANNOTBORDERSTYLE], 1,
+ [Define to 1 if we have the class `AnnotBorderStyle'.])])
+AC_CACHE_CHECK([for class EmbFile in Catalog.h],
+ [kpse_cv_have_EmbFile_in_Catalog_h],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <goo/GooString.h>
+#include <Object.h>
+#include <Array.h>
+#include <Catalog.h>]],
+ [[EmbFile *ef;]])],
+ [kpse_cv_have_EmbFile_in_Catalog_h=yes],
+ [kpse_cv_have_EmbFile_in_Catalog_h=no])])
+AS_IF([test "x$kpse_cv_have_EmbFile_in_Catalog_h" = xyes],
+ [AC_DEFINE([EMBFILE_IN_CATALOG_H], 1,
+ [Define to 1 for the class `EmbFile' in <Catalog.h>.])])
+AC_LANG_POP([C++])
+KPSE_RESTORE_FLAGS
+
dnl Write output here, instead of putting a zillion -D's on the command line.
AC_CONFIG_HEADERS([w2c/c-auto.h:c-auto.in],
[sed -e 's/^#define PACKAGE/#define WEB2C_PACKAGE/' \