summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-04-15 11:31:48 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-04-15 11:31:48 +0000
commitbaca7ad14b15829e67151e08e25e35b916046c4e (patch)
tree0400e2d2aadf117677c0993feaa712deecd5df6c /Build/source/texk/web2c/configure.ac
parente4f537c4f2f520fd294def7658650ee576abdf57 (diff)
texk/web2c: better handling of -ldl, used only for luaTeX
git-svn-id: svn://tug.org/texlive/trunk@17877 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 823a00e014a..b0f3e4cc04b 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -101,6 +101,14 @@ if test "x$kpse_cv_have_win32" = xno; then
AC_SEARCH_LIBS([nanosleep], [rt])
LIBS=$kpse_save_LIBS
AC_SEARCH_LIBS([dlopen], [dl])
+ if test "x$ac_cv_search_dlopen" != xno; then
+ AC_CHECK_HEADERS([dlfcn.h])
+ if test "x$ac_cv_header_dlfcn_h" = xyes; then
+ if test "x$ac_cv_search_dlopen" != "xnone required"; then
+ lua_socketlibs="$lua_socketlibs $ac_cv_search_dlopen"
+ fi
+ fi
+ fi
LIBS=$kpse_save_LIBS
AS_CASE([$ac_cv_search_inet_aton],
["none required"], [],
@@ -359,7 +367,4 @@ AC_CONFIG_COMMANDS_POST([AS_IF([test "x$cross_compiling" = xyes],
CC='$BUILDCC' CPPFLAGS='$BUILDCPPFLAGS'\
CFLAGS='$BUILDCFLAGS' LDFLAGS='$BUILDLDFLAGS'"])])
-dnl for luaTeX dynamic loading
-LT_LIB_DLLOAD
-
AC_OUTPUT