summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2009-06-03 00:05:21 +0000
committerKarl Berry <karl@freefriends.org>2009-06-03 00:05:21 +0000
commit186368070c9cdd94bce27758ebadb699bc440c2f (patch)
treee3e812342e2b58eedaa2a70c0bdfd8f1c7e26fe9 /Build/source/texk/web2c/configure.ac
parente282e1aa535d65add175b7c0f719e49ee5eb1a79 (diff)
use echo|grep instead of risking nested quotes
git-svn-id: svn://tug.org/texlive/trunk@13589 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 1bb30f4d901..af1db20d367 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -45,7 +45,7 @@ m4_include([ac/web2c.ac])
AS_CASE([$with_tex_banner],
[''|yes|no], [with_tex_banner="Web2C $WEB2CVERSION"],
- [AS_IF([test -z `echo "$with_tex_banner" | sed -n "/ $WEB2CVERSION/p"`],
+ [AS_IF([echo "$with_tex_banner" | grep -v "$WEB2CVERSION" >/dev/null],
[AC_MSG_ERROR([Bad `--with-tex-banner=$with_tex_banner' version string (must contain ` $WEB2CVERSION')])])])
AC_DEFINE_UNQUOTED([WEB2CVERSION], [" ($with_tex_banner)"])