summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-12-29 14:32:45 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-12-29 14:32:45 +0000
commit9da2af345bbc3848d181319a77b830c77034ae1e (patch)
tree74832eb1c57486b7ce18e0d987150cbdf42876a9 /Build/source/texk/web2c/Makefile.am
parenta7c9a7ff1a6d0925eafe21175304c494e266b319 (diff)
build system: Enable "silent rules" (see Automake manual)
git-svn-id: svn://tug.org/texlive/trunk@28654 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/Makefile.am')
-rw-r--r--Build/source/texk/web2c/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/Build/source/texk/web2c/Makefile.am b/Build/source/texk/web2c/Makefile.am
index 40d20ef7d75..0b386fd17b9 100644
--- a/Build/source/texk/web2c/Makefile.am
+++ b/Build/source/texk/web2c/Makefile.am
@@ -44,7 +44,7 @@ web2c = $(SHELL) ./web2c-sh $@
## We put this in the web2c directory because it runs on the build system, it
## is separate from (and simpler than) the actual web-to-C conversion programs.
-makecpool = web2c/makecpool
+makecpool = $(AM_V_GEN)web2c/makecpool
# Additional dependencies:
web2c_common = web2c/convert web2c/common.defines
@@ -110,13 +110,27 @@ $(proglib): ${srcdir}/lib/*.c
buildenv = TEXMFCNF=$(srcdir)/../kpathsea
# Calling tangle & Co.
-tangle = WEBINPUTS=.:$(srcdir) $(buildenv) $(TANGLE)
-tangleboot = WEBINPUTS=.:$(srcdir) $(buildenv) $(TANGLEBOOT)
+tangle = $(tangle_silent)WEBINPUTS=.:$(srcdir) $(buildenv) $(TANGLE)
+tangleboot = $(tangle_silent)WEBINPUTS=.:$(srcdir) $(buildenv) $(TANGLEBOOT)
+tangle_silent = $(tangle_silent_@AM_V@)
+tangle_silent_ = $(tangle_silent_@AM_DEFAULT_V@)
+tangle_silent_0 = @echo " TANGLE " $@; $(SHELL) ./silent-sh $@ #
+tangle_silent_1 =
+#
ctangle = $(buildenv) $(CTANGLE)
-tie = WEBINPUTS=.:$(srcdir) $(buildenv) $(TIE)
+ctangle_silent = $(ctangle_silent_@AM_V@)
+ctangle_silent_ = $(ctangle_silent_@AM_DEFAULT_V@)
+ctangle_silent_0 = @echo " CTANGLE " $@; $(SHELL) ./silent-sh $@ #
+ctangle_silent_1 =
+#
+tie = $(tie_silent)WEBINPUTS=.:$(srcdir) $(buildenv) $(TIE)
+tie_silent = $(tie_silent_@AM_V@)
+tie_silent_ = $(tie_silent_@AM_DEFAULT_V@)
+tie_silent_0 = @echo " TIE " $@; $(SHELL) ./silent-sh $@ #
+tie_silent_1 =
# Calling tangle & Co. via tangle-sh (several output files)
-texmf_tangle = WEBINPUTS=.:$(srcdir) $(SHELL) ./tangle-sh $@ $(TANGLE)
+texmf_tangle = WEBINPUTS=.:$(srcdir) AM_V_P=$(AM_V_P) $(SHELL) ./tangle-sh $@ $(TANGLE)
# For trip, trap, and other tests
DIFF = diff