summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-04 13:39:09 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-04 13:39:09 +0000
commit4cfbad84bfbfa4570d3d8951fd08ee86d834e577 (patch)
treeae28fa75d23866396b8e482c1da5cb70f3cecf90 /Build/source/texk/web2c/Makefile.am
parenteae91dcae12cec7698738cae0368b981df5b314c (diff)
new make target triptrap
git-svn-id: svn://tug.org/texlive/trunk@17311 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/Makefile.am')
-rw-r--r--Build/source/texk/web2c/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/Makefile.am b/Build/source/texk/web2c/Makefile.am
index 503d530848f..e6de8dbd64b 100644
--- a/Build/source/texk/web2c/Makefile.am
+++ b/Build/source/texk/web2c/Makefile.am
@@ -33,6 +33,7 @@ EXTRA_LIBRARIES =
EXTRA_DIST = PROJECTS cftests config.h cpascal.h help.h
DISTCLEANFILES = $(EXTRA_LIBRARIES)
CLEANFILES =
+TRIPTRAP =
# in case of an SVN repository
dist-hook:
@@ -118,6 +119,12 @@ DIFF = diff
DIFFFLAGS =
TESTS_ENVIRONMENT = DIFF='$(DIFF)' DIFFFLAGS='$(DIFFFLAGS)' LN_S='$(LN_S)' KPSEWHICH='$(KPSEWHICH)'
+.PHONY: triptrap
+triptrap:
+ srcdir=$(srcdir) MAKE=$(MAKE) \
+ $(SHELL) $(srcdir)/triptrap-sh $(TRIPTRAP)
+EXTRA_DIST += triptrap-sh
+
# The environment for making dumps.
# No need to specify TEXMF, as ../kpathsea/texmf.cnf should contain
# suitable absolute paths at this point. Those are converted to