summaryrefslogtreecommitdiff
path: root/Build/source/texk/upmendex/configure.ac
diff options
context:
space:
mode:
authorTakuji Tanaka <KXD02663@nifty.ne.jp>2016-02-09 11:02:48 +0000
committerTakuji Tanaka <KXD02663@nifty.ne.jp>2016-02-09 11:02:48 +0000
commitadec059e95b8e5728d8fb2d8420c5e928812c282 (patch)
tree28d38c44042fea2befbccbdd71063c801518d298 /Build/source/texk/upmendex/configure.ac
parentb0bdd8cd0fed764f189d773b0b0f69d25415a8f5 (diff)
texk/upmendex: upmendex 0.50
git-svn-id: svn://tug.org/texlive/trunk@39638 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/upmendex/configure.ac')
-rw-r--r--Build/source/texk/upmendex/configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/Build/source/texk/upmendex/configure.ac b/Build/source/texk/upmendex/configure.ac
new file mode 100644
index 00000000000..35efae51a9a
--- /dev/null
+++ b/Build/source/texk/upmendex/configure.ac
@@ -0,0 +1,40 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2010-2014 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([upmendex (TeX Live)], [0.50])
+AC_PREREQ([2.63])
+AC_CONFIG_SRCDIR([main.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([upmendex], [no-define])
+
+AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
+
+m4_include([../../version.ac])[] dnl define tex_live_version
+AC_DEFINE([TL_VERSION], ["TeX Live tex_live_version()"],
+ [Define to the current TeX Live version string.])
+
+AC_CACHE_CHECK([if C99 variadic macros are supported],
+ [kpse_cv_have___VA_ARGS__],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>
+#define foo(format, ...) printf(format, __VA_ARGS__)]],
+ [[foo("%s\n", "Hi, there");]])],
+ [kpse_cv_have___VA_ARGS__=yes],
+ [kpse_cv_have___VA_ARGS__=no])])
+AS_CASE([$kpse_cv_have___VA_ARGS__],
+ [yes], [AC_DEFINE([HAVE___VA_ARGS__], 1,
+ [Define to 1 if you have C99 variadic macros.])])
+
+KPSE_KPATHSEA_FLAGS
+KPSE_ICU_FLAGS([icuio icui18n], [--ldflags-icuio])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT